Network internet access problem - help!

Discussion in 'Mac Apps and Mac App Store' started by johnnyjibbs, Feb 21, 2004.

  1. johnnyjibbs macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #1
    Today I can't access the internet from my PowerBook, using my uni dorm ethernet connection.

    iChat AV and Mail work, but web browsing, MSN and Fire do not. I can still browse the SMB network in the Finder. This post is coming to you from Netscape, which is the only browser I have (out of Safari, IE, Camino and Netscape) that currently works! I know that it doesn't use the network settings information, but it's own version, and is automatically configured to retrieve the network proxy settings from a website. However, I can't get those settings to work when I plug them into the network preferences proxies panel (Safari says "can't find server").

    If I disable the proxy settings (for HTTP, HTTPS and FTP), I can access my local university pages but nothing on the internet. When I enable the proxy settings again, I can't even access the local intranet pages. The thing I don't understand is that the proxy ports and settings are the same as they were before.

    This was all working fine until this morning so I'm not sure what's going on. The only thing I did was type in that Terminal code line to enable fast boot-up of 10.3.2. It worked and has cut boot times to 45 seconds, even though I don't know what it did, but I hope it hasn't caused this problem!

    Anyone any idea what is going on? I could contact my local IT helpdesk, but I'd have to wait 'til Monday and they don't support Macs.

    Thanks.
     
  2. IndyGopher macrumors 6502a

    IndyGopher

    Joined:
    Nov 3, 2001
    Location:
    Indianapolis, IN
    #2
    What terminal command are you referring to? If I knew what you entered, I might be able to figure out what it did. I know one way to cut boot times on PC's is to disable DHCP, which could account for the problems you're having... depending how the routers at your university are configured. (IE, did you have to register your MAC address when you set up your computer on the network? Does all network traffic go through proxies, or is that optional? etc)
     
  3. johnnyjibbs thread starter macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #3
    Here's the command I typed...

    sudo ln -s /System/Library/Extensions/BootCache.kext/Contents/Resources/BootCacheControl /usr/sbin/BootCacheControl

    which is from the thread "Speed up your 10.3.2 boot time."

    It worked as they said, although there was some strange unix programmer comment about being given a lecture about something immediately after I pressed enter.

    Yes, I had to register to be 'let in' to the network. I've checked all my proxy settings along with the ones they told me to enter also and they are the same as before. It appears that Netscape works because it is the only browser that doesn't use the system preferences proxy settings ( although I can't get the system preferences to work when using Netscape's automatic settings!)

    I've tried umpteen restarts (now quick thankfully!) but it still doesn't work.
     
  4. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #4
    The terminal command did not do much except to put the bootcachecontrol in usr/bin where teh system looks first when it boots up..
    anyways to undo the change you can write
    sudo rm /usr/sbin/BootCacheControl

    so you can try that and check if things go back to normal..although i have done the same thing on my comp and nevr had the problem..anyways u cn check it out..
    cheers
     
  5. johnnyjibbs thread starter macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #5
    Thanks for your help. I entered that command and rebooted, but it has not fixed my problem. I sort of understand what that is doing at least.

    I thought maybe my network was down but it can't be if Netscape is able to access it. Perhaps something has corrupted in my system preferences, but I'm not sure how to revert it and set it up again.

    With the firewall in place, we need a proxy setting for FTP, HTTP and HTTPS only (at least that's what they tell us). All these settings are as it was before but it still doesn't work. I don't understand!
     
  6. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #6
    try repairing permissions
    sorry not to be of more help
     
  7. johnnyjibbs thread starter macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #7
    Ok, strange.. I'm up and running again now! I repaired permissions - that fixed a couple of things to do with my printer (?!) but didn't correct my problem. I tried the fast boot-up thing again and that didn't do anything again. (I tried to search for BootCacheControl in the Finder but couldn't find it - is it a hidden file? Is that why you need the terminal?) I think the terminal command was a red herring.

    Anyway, I was at wit's end, but then I tried "Automatic Proxy Configuration" again, and put in the URL that was in the Netscape preferences in it. Before it didn't work, but then now it did, and Safari was working again. However, Fire (chat client) was not, nor was MSN (that requires its own proxy preference). Then I had the bright idea to try to open up the prox.config file using TextEdit and it worked. It's only about 5 lines long and, although I couldn't understand the code, I got the gist of it. This time it had two proxies - the one I had been using all along, and one with a '2' before the domain name. I plugged this into the network settings and now everything works again. No idea why.

    Maybe someone could enlighten me? Anyway, thanks for all your help.

    EDIT: I thought it might fix my MSN Messenger timeout probloem (where it logs off every 15 or so minutes and I have to re-log back on) but it didn't, so I guess I'm back to using Fire...
     
  8. abhishekit macrumors 65816

    abhishekit

    Joined:
    Nov 6, 2003
    Location:
    akron , ohio
    #8
    gr8 its all workin now..Bootcache control is a hidden file, you wont see it in Finder. To see it open terminal write cd .. , then again write cd ..
    then write cd usr/sbin
    then write ls -a
    it would show Bootcache control..
    As per your original problem and its subsequent solution, I dont know man..I would also liek to be enlightend ..
    :)
    cheers
     
  9. johnnyjibbs thread starter macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #9
    A wrote an email to my IT helpdesk just to tell them about my problem and how I fixed it. They probably won't get to read it until tomorrow but at least it will alert them of any problem or they may be able to tell me what changed and why.

    Thanks for your help :)
     

Share This Page