Network problems behind server gateway.

Discussion in 'Mac OS X Server, Xserve, and Networking' started by RTee, Jun 12, 2008.

  1. macrumors regular

    May 26, 2008

    I'm hoping someone can help shed some light on the issue I'm having with my server.

    The server is an OD master and running as the gateway. Mail, ical, NAT and DHCP are working OK, all clients are bound to the directory.

    But when trying to setup server based Home folders though what happens is that after I configure sharing and automount on the designated home folder it lists as in WGM and not the server name which is what I have seen in tutorials and my clients resolve to. Whether this is correct or not clients can only resolve to

    Home directories are created fine in the specified home folder but my clients can't see only and if I add a custom path in WGM/Home to etc it will not create the home folder, only when it's set to which is there automatically after setting up automount.

    On the client machines under Network/Servers I do see the folder and inside an alias to the home folder but it doesn't resolve.

    Clients are also unable to get to the webpage but can to but on the server loads just fine.

    I'm surely missing something in my config, hopefully something silly.

    In my DNS setup I have the following:

    > Primary Zone -
    server Machine

    > Reverse Zone - Reverse Mapping

    Appreciate any help.

  2. thread starter macrumors regular

    May 26, 2008
    Found a solution.

    OK I've now got this working, whether it's a work around or the way to do it I have no idea.

    In DNS I added the following:

    > Primary Zone -
    "servername" Machine External IP address (static IP from ISP) Machine ALIAS

    > Reverse Zone - Reverse Mapping

    >external Reverse Zone -
    external IP Reverse Mapping

    The reverse mappings were added automatically.

    Have since tested and can log on to home folders on the server and browse
    to both and

    I'd still be interested in hearing from anyone who thinks we initially should have seen the auto path to the home folders in WGM list as instead of


Share This Page