networking Mac and PC, internet sharing too

Discussion in 'Mac Help/Tips' started by vniow, Dec 1, 2002.

  1. vniow macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #1
    Hi, I just bought a new ethernet card for my PC since the old one went kaput and I'm trying to hook my iBook up to it so I can share files and surf the internet on both.
    I'm using XP pro on my PC and 10.2 on my iBook and yes it's a crossover cable if that matters at all.

    The PC's the one connected to the internet all the time, I already have enough cables coming from my iBook, don't need any more.[​IMG]

    Anyone? (stupid Mac newbie questions, I know...)[​IMG]
     
  2. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #2
    Never mind, for some reason it works now.

    On the iBook, typing through ethernet.
     
  3. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #3
    almost...

    I can surf the internet fine, but neither computer can read the other's files.

    Dammit.
     
  4. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
    #4
    A little kludgey, and it only sometimes works, but: create a workgroup on the PC, open Directory Services on the Mac, select SMB, hit configure, and add the workgroup name to the list of workgroups (IIRC, it only has WORKGROUP by default). The use connect to server and the Mac should be able to read any shared volumes or folders.
     
  5. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #5
    Okay.....umm......oh boy.......how and where would you go about doing that?

    (already got a workgroup on the PC it's the Mac that I know nothing about.[​IMG]
     
  6. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
    #6
    (Note to self: check solutions for completeness and accuracy before posting :eek: )

    Sorry about that... it's Directory Access in /Applications/Utilities. Click the lock to make changes, enter your password, select SMB, click configure. Type the name of the workgroup, and (if applicable) the WINS server IP. Then click OK, then quit, and save on the prompt. That SHOULD work.
     
  7. BenderBot1138 macrumors 6502

    Joined:
    Oct 28, 2002
    #7
    Is SMB the only way?

    For Windows 2000/XP
    1 Run Regedit and goto HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkStation\Parameters.
    2Make a DWORD value EnablePlainTextPassword and assign a value of 1.
    3Reboot your XP (XeroxPark ;) wannabees)
    4Browse Network Neighborhood for shares

    For the exact description, visit the below link, it's exact and better than the above method. GeeYouEye can also clarify whether this is still necessary or not.

    That's for the SMB (CIFS). There might be easier ways... I'm sure there must be. Info on SMB and the above from Apple Developer site originally by someone named Jason Deraleau.

    I'm interested to see if there isn't a much simpler post Jaguar release way. I'm sure someone at MacRumors must have the inside on this.

    :cool:
     
  8. zimv20 macrumors 601

    zimv20

    Joined:
    Jul 18, 2002
    Location:
    toronto
    #8
    is sharing on?

    for the PC to see the Mac files, is Mac sharing on?

    control panels / sharing / personal file sharing / <start button>

    i couldn't tell you how to turn on windows file sharing. but you're a windows person, yes?
     
  9. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #9
    File sharing is turned on the PC as well as the iBook (yes I've got the Mac sharing on, at least I think I do)

    But I couldn't assign any value to the DWORD file in the registry (the registry has got to be the worst idea ever) it keeps giving me an 'invalid DWORD value'.

    This shouldn't be so difficult, all I want to to is transfer a few files, maybe this would be easier if I had Firewire.........

     
  10. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #10
    Yo, anybody?

    Getting a new hard drive tomorrow and all my stuff's going to be gone if I can't save it.........
     
  11. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #11
    OK, lets go start to finish:

    What you need:
    Both machines connected to each other via some kind of ethernet.
    Assign an IP to each machine, e.g >
    Mac: 192.168.0.1
    PC: 192.168.0.2
    Subnet masks on both of: 255.255.255.0
    Default gateway: shouldn't matter

    Now disable any firewalls running on both boxes (inc. the built in one's in each OS).

    Now check that from each machine you can ping the other.
    Mac: applications > utilities > terminal > type "ping 192.168.0.2 -c 1"
    PC: start > Run > type "cmd" then return > type "ping 192.168.0.1"
    If both reply then both machine are seeing each other OK.

    Now on your XP box share a folder. Do this by right clicking on a folder and then selecting "properties", go to the sharing tab and enter a share name (without any spaces).

    Now on the Mac go Finder > Go > Connect to server and enter:
    smb://pcworkgroupname;pcusername:pcpassword@pcipaddress/sharename
    This should now mount the PC share on you Mac and you can now copy stuff over to it so that you can then copy it back to your new Mac HDD later on.

    Hope this helps. :)
     
  12. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #12
    I thought Rendezvous was supposed to make it easy!!

    I hate networking. I sincerely hope I never have to go through this ever again.


    IP of XP box: 192.168.0.1 (assigned by me)
    IP of iBook: 192.168.0.43 (assigned by iBook)
    Name of workgroup: MSHOME (default)
    Name of XP box: HI
    Name of iBook: Me-Sez-yous
    Shared folder on XP box: MyPictures


    They can ping each other fine but when I try to connect to server on the Mac, it gives me an error.
    Does it matter if I don't have a password on either cuz I don't and that's where I seem to get stuck.


    Hell maybe I should save up for a new one with a CD burner or Firewire so I can transfer files easier. Or maybe I should get a hub but I don't want to waste money on something that will only be used on two computers where a simple crossover cable should be all I need.

    I hate networking.


    Blah.


    **Anyone want to buy a 300Mhz Blueberry iBook with 10.2 preinstalled and the discs? It's in pretty good condition, few scratches on the bottom but that's about it.

    Anything to get out of this networking hell.


    **That was a joke if you didn't haven't already noticed. Sorta.
     
  13. gbojim macrumors 6502

    Joined:
    Jan 30, 2002
    #13
    Since you are connecting to the Internet from your iBook, you will be happy to know that you do not have a "network problem" so you're out of network hell.

    So what is the error message you get when you try to connect from the iBook to the PC?
     
  14. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #14



    I don't get an error message when I connect them, it's when I try to 'Connect to server' on my Mac when I get the message: 'An error has occured (error = -5203)
     
  15. BenderBot1138 macrumors 6502

    Joined:
    Oct 28, 2002
    #15
    sorry for the delay in response...

    make sure you check this site and cover all the basics.

    Since you want "file sharing", SMB (CIFS) aka SaMBa, appears to be the way. I'm still not convinced that there isn't an easier way, but remember we are working with PC's here.

    Connecting two macs is childsplay, but introduce a PC and man alive! What a ridiculous thing. Even two identical PCs are totally ridiculous.

    ok with the DWORD try to assign 1 (0x01) but follow this info - click here. If you've made several changes, based on info in this post, it's entirely possible that you have cross-set some settings, mixing two methods of making the connection. The DWORD issue is explained in the links above, and there is also an email address for the SMB tutrial there.

    Sorry for the delay again... hmmm... do you have SMB installed and configured on your mac? I'm going to check to see if the big cat (Jaguar) does it all for you, but it's also a free download here according to Jason Deraleau. I still think you have to start SMB though.

    To start SMB sharing on your Mac, go to your System Preferences Sharing Pane. Next, create your account for your PC in the System Preferences Accounts Pane. Be sure to select the checkbox "Allow User to Log in from Windows." Someone else here might be able to clarify if this is right...

    :cool:
     
  16. gbojim macrumors 6502

    Joined:
    Jan 30, 2002
    #16
    When I said connect from the iBook I was referring to making the logical connection to the XP share, not plugging it into the network.

    From my experience, the error message you are getting is the catchall.

    Try specifying the connection string as: smb://192.168.0.1/MyPictures. I have found that if the Mac cannot find the Windows workgroup it will often not connect properly because it can't find the machine. Using the IP address bypasses the workgroup and computer name components.

    Also, the previous posts about changing the registry on the Windows box is for when you are trying to connect from a Windows client to a Mac server running Samba, not when you are trying to connect from a Mac client to a PC. I highly recommend NOT changing the registry manually. In fact, if you made this change you should put it back. Otherwise, if you try to connect your PC to another XP box it will most likely refuse the connection. The setting basically tells XP to not encrypt your password when connecting to a network share.
     
  17. Rajj macrumors 6502a

    Rajj

    Joined:
    May 29, 2002
    Location:
    32° 44' N 117° 10' W
    #17
    It's the windows part that sucks……anyway….. You have to run the network wizard from windows, Start-->Control Panel--> Network and Internet Connections--> Set up or change your home or small office network--> follow the wizard instructions and reboot the computer!!!
    I assume you have windows file sharing enabled on the Ibook????

    For more information click here andhere
     
  18. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #18
    Okay I just specified the connection string without the workgroup, it prompts for a password (of which there is none), I click OK and it gives me that same error message.


    I already did the 'Set Up New Network' thingie in Windows and yes 'Windows File Sharing' is turned on.

    I still hate networking.
     
  19. BenderBot1138 macrumors 6502

    Joined:
    Oct 28, 2002
    #19
    Where's my Mac?

    By default, your Mac is set in "WORKGROUP" on the Windows network work group - have you seen it there at all? You can change that using Jaguar's Directory Access utility though.

    :cool:
     
  20. Rajj macrumors 6502a

    Rajj

    Joined:
    May 29, 2002
    Location:
    32° 44' N 117° 10' W
    #20
    Networking is the best if you know how to use it!!!
    Anyway…. Did you try to connect to the Mac from the PC?
    Also I would run the network wizard again and change the workgroup to MSHOME, make a password and reboot.
    Did you check out the linx I provided? :confused: :confused:
     
  21. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #21

    If my PC could even detect my Mac, then I would try to connect to it.

    Whenever I run the Network Wizard, it doesn't ask me for a password so I can't input one.

    And yes I did check out those links, but they basically restated what people have said here.


    I'm seriously thinking that the little money that I have would have been better spent on a down payment or whatever on a new one.

    Blah.
     
  22. vniow thread starter macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #22
    Holy sh|t, I somehow got it to work.

    I was screwing around with some of the network settings in Windows and changed a couple passwords and now both computers can share files!!

    Thanx for all your help guys.[​IMG]
     
  23. gbojim macrumors 6502

    Joined:
    Jan 30, 2002
    #23
    A friend just dropped in with her laptop so I tried exactly what you are doing. I messed up one thing in the address in the previous post:

    cifs://192.168.0.1/MyPictures

    I logged into the XP box providing a username and there is no password. It worked no problem. I did not think the cifs vs smb would make a difference but it did in this case.

    The only thing you are doing that we are not is the Internet sharing on the XP box. So, if that path does not work, there must be some reason the XP box is rejecting the connection.

    You could always try using FTP as opposed to Windows sharing and just transfer the files that way. Enable the FTP server on the Mac and create a drop box.

    I'm heading out for a while so I won't be able to respond any more this evening. Hope it all works out.
     
  24. BenderBot1138 macrumors 6502

    Joined:
    Oct 28, 2002
    #24
    Great!!!

    See if as the cherry on top here if you can summarize for others in the future the steps taken to accommplish all this... Think of it as a nice MacRumors threaded tutorial and and explaination of the issues involved and items needed to accomplish the whole process. I'll bet some future visitors will appreciate it very much.

    :cool:
     

Share This Page