New 27'' iMac Slow and Laggy for no reason!

Discussion in 'iMac' started by miguelcoma, May 3, 2013.

  1. miguelcoma, May 3, 2013
    Last edited: May 6, 2013

    macrumors newbie

    Joined:
    Feb 18, 2012
    #1
    PROBLEM SOLVED, Forward to my last post here for the solution

    Hi, I've had my new iMac since January 14th and had no problems till yesterday.
    For some reason it is really choppy and laggy, specially with internal animations such as mission control, hiding apps to dock, opening apps or showing the desktop.
    But I swear to god it was incredibly smooth till yesterday.

    I've got a 27'' iMac 3,4Ghz i7, 24GB Ram, 1TB HDD and NVidia GTX 680M
    I've checked RAM and CPU usage with almost no app running and it's still slow, although I've got 20GB free RAM and 95% free CPU usage.

    I also logged of my session and logged in Guest user, and it is still laggy. Also rebooted a couple of times, still nothing. Also, I repaired Disk Permissions and have 270 of 700GB free HDD Space. (resting 300GB are for my Windows Partition)

    NOW, HERE'S THE INTERESTING PART:
    I've previously played Portal 2 at max settings and 60FPS on my computer.
    And now, if I play it again, at max settings, it still runs at 60FPS according to the game BUT it feels a little laggy compared to how smooth it was before.
    So I'm gessing, if it says it runs at 60FPS but doesn't feel like it, should that had to do something with the graphic card adapter?


    I made a video of the problem and took a screenshot of processes running while on Guest Account:

    this video shows pretty well how laggy it is.
    http://www.youtube.com/watch?v=1G5cjQF79bo&feature=youtu.be
    another video
    http://www.youtube.com/watch?v=fzddtVWV2l8
    [​IMG]
     
  2. macrumors 65816

    Joined:
    Jul 7, 2008
  3. macrumors 603

    justperry

  4. thread starter macrumors newbie

    Joined:
    Feb 18, 2012
  5. macrumors regular

    Joined:
    Dec 8, 2005
    Location:
    GR
    #5
    I guess the only thing left to try is boot from a freshly installed system, use an external disk. If the problem persists then you should call Apple.
     
  6. macrumors 603

    justperry

    #6
    By the way, if you post a screenshot of Activity Monitor you should always select ALL processes in the drop down Menu on top, then select System Memory tab in the lower part and in the main body click on the %CPU tab to show the most active processes on top.
     

    Attached Files:

  7. thread starter macrumors newbie

    Joined:
    Feb 18, 2012
    #7
    Wait, so the only way to solve it is reinstalling OSX from scratch?
    How's that possible?
     
  8. macrumors 603

    justperry

    #8
    No, it's almost always if not always possible to solve it without reinstalling, if you startup in a new user and don't have the same issues it is the normal User Account which has problems, if both have problems the problem may be inside the main Library and can still be solved.
    When you have the problem make that screenshot as I said before and post it.
     
  9. thread starter macrumors newbie

    Joined:
    Feb 18, 2012
    #9

    OK, here are the screenshots:
    (Main account logged off, using Guest account. Just Running Safari.)

    Part I
    [​IMG]

    Part II
    [​IMG]


    SORTED BY CPU USAGE

    [​IMG]
     
  10. macrumors 603

    justperry

    #10
    If I were you I would try without Logitech drivers, so uninstall them, restart and see if that made a difference.

    (I see the Logitech Control Centre Deamon running)
     
  11. thread starter macrumors newbie

    Joined:
    Feb 18, 2012
    #11
    Ok, I uninstalled them and the problem remains... what can I do now? :(
     
  12. macrumors 603

    justperry

    #12
    Run the following command in terminal:

    kextfind -case-insensitive -not -bundle-id -substring 'com.apple.' -print

    then post the output here.

    Also, what is in these folders:

    /Library/LauchAgents
    /Library/LaunchDeamons
    /Library/StartupItems
    ~/Home/LauchAgents
    ~/Home//LaunchDeamons
    ~/Home/StartupItems
     
  13. thread starter macrumors newbie

    Joined:
    Feb 18, 2012
    #13
    Ok, Terminal command displayed this:

    In the folders you mentioned:
    /Library/LauchAgents This
    /Library/LaunchDeamons This
    /Library/StartupItems This Folder was empty

    As for this folders
    ~/Home/LauchAgents
    ~/Home//LaunchDeamons
    ~/Home/StartupItems
    I'm not exactly sure where to find them, but I thought it was in Home/Library/
    And in that folder I just found /LaunchAgents the others where missing. This is what's in it.

    By the way, thank you for all the help!!
     
  14. justperry, May 3, 2013
    Last edited: May 3, 2013

    macrumors 603

    justperry

    #14
    I am in a different timezone, that was my last post.

    Now, as for your Extensions and others.

    Extensions, I see a few of them which are not there by default but some of them are OK

    /System/Library/Extensions/hp_Inkjet8_io_enabler.kext
    This one is OK, printer drivers are tested well

    /System/Library/Extensions/LittleSnitch.kext
    I have this one, no problem here.

    /System/Library/Extensions/LogMeInSoundDriver64.kext
    I know LogMeIn, this could potentially be a problem although I doubt it

    /System/Library/Extensions/TelestreamAudio.kext
    I have no idea what this is, it seems to be audio related but don't know what it does.
    Just looked it up, you seem to have screenflow 4, uninstall and see if it helps, you might have to restart since it is an extension.


    As for the other Folders
    LauchAgents
    LaunchDeamons
    StartupItems

    These are standard Folders but empty when you have a new Install, these folders are standard only in /Library but not in your ~/Home/Library folder, if there are no folders like these inside your Home/Library folder there is no problem, but some Apps will create these.

    I saw one I don't know, the rest seems to be OK.
    com.hamachix.tuncfgd.plist in /Library/LaunchDeamons

    Seems like a VPN from Computer to computer, something to do with LogMeIn.

    I had LogMeIn a while ago but don't like this software, installs way too much crap everywhere.
    Uninstall restart and see if it is better.

    Now, I said uninstall two software packages but before you do you can do other things, like holding the shift key when logging into your User Account, do this right after you hit Enter, see if this works, if not restart and hold the shift key instantly after restarting or starting up, this will get you into safe boot, what does it do now, still have problems or not?
    I safe boot only loads the default system without startupItems, 3rd party Extensions-LaunchAgents/Deamons amongst more stuff.

    I hate Apps which install stuff for no reasons at all, LittleSnitch needs an extension to prevent incoming traffic, I'll give you an example for software which is not needed, for instance WD, WD installs for instance extensions, for what, it's just an effing Harddisk!

    I always check what Apps installs, I do this with an App called Pacifist, if the installer is a .pkg file or when I open an installer by right clicking on it and there is a .pkg (Or mpkg) inside I open it with Pacifist first.

    There is one more thing to look at, open console and see in system log if you see errors reoccurring again and again, sometimes it tells where to look.
     
  15. thread starter macrumors newbie

    Joined:
    Feb 18, 2012
    #15
    I did all that and also booted in safe mode, but still the problem remains. :(
    This is driving me craaaazy

    Is it possible that it has something to do with the cache?
     
  16. macrumors 603

    justperry

    #16
    Yeah frustrating.

    Since it didn't help yet you should run 3 diagnostic programs, first run Disk Utility and run check disk, if there are no errors run Apple Hardware test and Memtest.

    Intel-based Macs: Using Apple Hardware Test

    MemTest

    When you are on MemTest page you better click on guide and read how to run it from Single User Mode, this is much better than running it in OS X.
     
  17. macrumors newbie

    Joined:
    May 4, 2013
    #17
    logitech mouse dongle issue

    have you tried unplugging the logitech usb dongle? i have had this problem with my mouse in the past and this helps. i haven't seen this with ML.
     
  18. macrumors 601

    BornAgainMac

    Joined:
    Feb 4, 2004
    Location:
    Florida Resident
    #18
    I had the same problem and it ended up being my Bootcamp partition causing my Mac to be slow. My theory was Spotlight was trying to index that drive but never confirmed since I just got rid of Bootcamp completely.

    My 2010 iMac now runs as expected.
     
  19. miguelcoma, May 6, 2013
    Last edited: Oct 16, 2013

    thread starter macrumors newbie

    Joined:
    Feb 18, 2012
    #19
    HEY GUYS!
    Some dude from another forum solved my problem!
    If anyone has a similiar issue, please do the following, it really helps:

    That did the trick and my iMac is now fast and smooth again.
    Kudos to black_ice from applesfera for finding the solution to my problem!!
    And thanks to all of you for your help! :) :)
     
  20. macrumors 603

    justperry

    #20
    Good to know, glad you solved it.
     
  21. macrumors 6502

    eattherich

    Joined:
    Jul 8, 2011
    Location:
    Berlin
  22. macrumors newbie

    Joined:
    May 7, 2013
    #22
    Perfect

    Worked like a charm!!!! A thousand Thank you!!!!

    " Step 1: Delete system windowserver preferences
    In the Finder, from the menu bar, select "Go -> Go to Folder..."
    Enter: /Library/Preferences/
    Delete the file called com.apple.windowserver.plist

    Step 2: Delete user windowserver preferences
    In the Finder, from the menu bar, select "Go -> Go to Folder..."
    Enter: ~/Library/Preferences/ByHost/
    Delete all files that start with com.apple.windowserver (On my rMBP, there was one file called com.apple.windowserver.12AFB147-95D6-5C70-8F62-C1E4F2BE81BE)

    [OPTIONAL] Step 3: Reset the PRAM
    (These instructions are from http://support.apple.com/kb/HT1379)
    Shut down your Mac.
    Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    Turn on the computer.
    Press and hold the Command-Option-P-R keys before the gray screen appears.
    Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    Release the keys. "
     
  23. macrumors regular

    FrogTastic

    Joined:
    Nov 20, 2008
    Location:
    United Kingdom
    #23
    Non of the suggestions helped, anyone got anything else?
     
  24. macrumors member

    Joined:
    Jun 29, 2009
    #24
    Thank you SO MUCH!
    My iMac was weirdly slow for no reason and now following those steps fixed everything on my two week old Late 2013 iMac!

    I'm so glad I found this post, I was about to reinstall my OS and everything, or even calling Apple for a new iMac.
     
  25. macrumors newbie

    Joined:
    Jun 13, 2007
    #25
    Sorted my Retina iMac problem!

    Hi,

    I know this is an old thread, but the com.apple.windowserver.plist deletion trick outlined here is the only thing that solved my problem with a new Retina iMac.

    The machine had been dreadfully sluggish, with visible delays in updates to the UI.

    I tried everything - thought it was Spotlight for a bit, even talked to Apple support a few times, with very little progress.

    I stumbled across this thread, figured I had nothing to lose from the plist solution and gave it a try. I did also do a PRAM reset - its possible that the plist deletions OR the PRAM reset alone would have fixed it, but there's likely no harm in doing both.
     

Share This Page