1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

New iBook + new memory = trouble (help me?)

Discussion in 'Macintosh Computers' started by rinseout, Jan 18, 2005.

  1. macrumors regular


    My new iBook 12" arrived this morning. The first thing I did was to carefully follow the instructions to install the 1 Gb of RAM I purchased from a retailer which arrived last week. (The RAM is "DMS Certified" brand).

    I fire up the 'book, (continue to) marvel at the niceness of it all, and then after fiddling I hop over to "About this Mac", only to see that I only have 256 Mb of RAM.

    OK, I thought, this is just because I've never installed RAM before and I'll just need to re-seat the bloody thing. So I open her up, take the memory out, put back in, and fire it back up. 256 Mb.

    I do it all AGAIN. Still 256 Mb.

    The current state of affairs: the iBook is charging for battery calibration and the non-detected RAM is still in there. I can see about 1/8" of contacts on the ram; the clips seem to snap into place properly. I have tried pushing in the module with light pressure, but I do not experience much "give", like when the airport card goes in. The clips, nevertheless, seem to be in the right spot.

    What do I do now, O Macrumors? I need a step by step on getting this working.

    It would be nice to know the odds on this being
    1) A simple (correctable) installation error;
    2) My having broken my computer within 5 minutes of owning it;
    3) A case of bad memory (will require return)
    4) A case of broken computer (will require return)

  2. macrumors 68040



    Is it the right ram, I know there was another MR member using the WRONG ram in his PMG5, are you sure you have PC2100 or PC2700 SO-DIMM, CL2.5, 200 pin.

    And did you ground yourself to get rid of the static current. :)

    Maybe the ram is not seated properly. :confused:
  3. macrumors regular

    Right RAM, right technique, wrong results.
    The thing fits in the slot, I purchased the RAM from a store (I don't want to mention them just yet) that markets this RAM specifically for my computer and has had good reviews, and I did ground myself.

    I'm really worried! :(
  4. macrumors 68040


    It could just be defective ram.

    Try running the Apple Hardware Test CD that was included in the Mac box. If it does not register the new ram dimm, call the vendor from where you bought it and ask for an exchange. Tell them that its defective, they will not charge for defective products. :)
  5. macrumors 6502

    iBook RAM

    I installed a 512MB stick in my wife's iBook, and ran into a similar situation.

    In the end, I just hadn't seated the RAM properly. I used apple's website instructions, and saw that I hadn't pushed it in far enough. I was surprised how much pressure was required for it to 'snap' into place.

    go to http://www.apple.com/support/ibook/doityourself/ and download the .pdf file and make sure you've followed all of the instructions, and look carefully at the pictures to make sure the RAM is completely inserted.

    If this all looks OK, it sounds like bad RAM.

  6. macrumors regular

    Looking at the pictures, it also looks to me that I may not have put it in properly. In the picture, you cannot see any of the contacts, but in my case, I can see 1/8" of the gold contacts on the memory.

    It didn't feel to me like there was any "insertion" happening when I put it in, but I thought I was still engaging the memory properly (even after pushing on it it would not go in further).

    I'll try again, and if that fails I'll be sending back the memory.

    It's kind of embarassing; I fancy myself somewhat technically inclined, but I'm having trouble with this.
  7. macrumors 68040


    There is a diagram in the iBook manual as well.

    It takes a little pressure to seat it in, it can be a little tricky however the dimm should snap into the 2 side grooves without hassle. :)
  8. macrumors newbie

    the first time i installed a RAM SIMM (yeah, SIMM, it was way back in the Performa Series days), i thought for sure i was gonna break it, cauz i had to push so hard to seat it properly.

    When it finally snapped in, it went with a huge BONK! and i cringed. But it started up fine and ran for years afterward. Don't be afraid to muscle the chip in if you have to. They're surprisingly resilient.

    The most important thing is to ground yourself and not touch the contacts. Godspeed!
  9. macrumors 65816


    rinseout, do let me know how your situation turns out, as I am exactly the same boat. (Except my iBook is about a year old and only certified by Apple to go to 640MB max, but by all reports -- including the store I purchased the chip from -- it will take a 1GB chip.)
  10. macrumors 6502

    I had your exact same situation with my iBook and a chip generously donated by a co-worker. I opened it up 3 times and fussed with that bugger, taking it in and out, yet it still wouldn't go.

    When I gave up in frustration and gave the chip back to my co-worker, he said, "oh, let me see it." He put the chip in, we booted it up, and bingo. WHere it once said 256 MB, it now said 384 MB.

    If your chip was bad chances are your 'book wouldn't even want to boot up. I've run into that before too. Macs are picky about ram.

    Give it another go, eh?
  11. macrumors 65816


    I just tried putting my 1GB chip in again -- shoving it in -- and the third time was the charm! rinseout, just throw some muscle behind it and you'll be good!
  12. macrumors regular

    thanks all for the help

    hi everybody,

    thanks for the help. it really is a question of muscling it in there. for future reference, if you see like 1/8" of gold contact, you're probably not pushing it in far enough.

    it made a crunchy noise which scared me half to death, but when I opened my eyes everything was OK. :)

    now i have to troubleshoot my airport trouble.

Share This Page