1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

New iMac airplaying XMBC to ATV 3rd gen, no sound

Discussion in 'Apple TV and Home Theater' started by jjg247, Sep 16, 2013.

  1. macrumors newbie

    #1
    Apologies if this has been covered previously, but I was not able to search the forums and find an answer for this.

    I have a new iMac and am trying to airplay XBMC to my television using an apply tv 3rd gen. When I do this the picture comes in well (not perfect, but will touch on this later) but absolutely no sound whatsoever. I have confirmed that I can stream audio and video to the ATV using other programs and that works. Not sure if its related, but the volume keys on the iMac keyboard do not control the volume from within XBMC. Anyone have any tips to get this fixed? Any assistance would be greatly appreciated.

    About the picture, there is a black frame around the picture preventing it from being shown in true full screen. It appears as though there is a picture frame around the video. I tried adjusting the settings on the computer to fit resolution to Mac and also fit resolution to apple tv and neither got rid of the box. Any ideas?
     
  2. macrumors newbie

    #2
    Audio output in XBMC was the culprit. Now to figure out the full screen problem.
     
  3. macrumors 65816

    Cnasty

    #3
    How did you fix this?

    I am having the same problem.

    I hear it fine on the mac but when running XBMC to airplay the sound doesnt come to the tv.

    I tried changing the output but still no luck.
     

Share This Page