New iMac Getting SPOD

Discussion in 'iMac' started by joeholl1979, Feb 21, 2013.

  1. macrumors member

    Joined:
    Jan 14, 2013
    #1
    I've been loving my new iMac, and haven't looked back since switching from PC. However, over the last few days I've been getting the Spinning Pinwheel Of Death, seemingly at random times. It's REALLY annoying because the only way I know to resolve it is hard boot the computer.

    Any help to permanently resolve this issue would be much appreciated!
     
  2. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    When you're getting beachballs, follow every step of the following instructions precisely. Do not skip any steps.
    1. Launch Activity Monitor
    2. Change "My Processes" at the top to "All Processes"
    3. Click on the "% CPU" column heading once or twice, so the arrow points downward (highest values on top).
      (If that column isn't visible, right-click on the column headings and check it, NOT "CPU Time")
    4. Click on the System Memory tab at the bottom.
    5. Take a screen shot of the entire Activity Monitor window, then scroll down to see the rest of the list, take another screen shot
    6. Post your screenshots.
     
  3. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #3
  4. thread starter macrumors member

    Joined:
    Jan 14, 2013
    #4
    Whenever this happens, the computer is completely frozen, so I won't be able to do that...
     
  5. macrumors member

    Joined:
    Jan 14, 2011
    #5
    I would run disk utility to make sure your hard drive is okay. I had a similar symptom, and turned out to be a bad HD. Good luck.
     
  6. TennisandMusic

    Joined:
    Aug 26, 2008
    #6
    This is actually one of the reasons I switched back from Mac to PC. OS X is simply incredibly slow, buggy, and just not performant.

    Go look at the articles posted at macperformanceguide.com to get an idea. My Windows install blazes...

    Good luck with your computer (no sarcasm).
     
  7. thread starter macrumors member

    Joined:
    Jan 14, 2013
    #7
    Ugh, that would suck...
     
  8. macrumors 6502a

    Joined:
    Sep 2, 2008
    Location:
    Metro Kansas City
    #8
    That's a riot!
     
  9. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #9
    Then do the System Memory part afterwards.
     
  10. macrumors newbie

    Joined:
    Feb 13, 2013
    #10
    My experience has been the complete opposite. I went without a reformat on my MBP for about three years -- and it started slowing down -- with windows I can't go more than a year without it bogging down. To each their own I spose.
     
  11. thread starter macrumors member

    Joined:
    Jan 14, 2013
    #11
    It just did it again. I hard booted then took these screen shots.
    Screen Shot 2013-02-21 at 11.11.38 PM.png
    Screen Shot 2013-02-21 at 11.13.46 PM.png
     
  12. macrumors 6502

    Joined:
    Feb 7, 2013
    #12
    1) open system pref's and put your hard drive in spotlight exclusions. This will wipe away your .DS_Store files.

    2) Reboot and go into recovery. Repair your HD and then repair permissions

    3) Reboot again and remove your hard drive from spotlight exclusions.

    Now wait while your drive is reindexed. You can work on it but don't mess with spotlight until it is finished. This should help if mds is really going wild.
     
  13. thread starter macrumors member

    Joined:
    Jan 14, 2013
    #13
    This didn't quite work, but it did make me realize that Spotlight was probably causing the issue. I reset the PRAM and now Spotlight is re-indexing my hard drive. So far, no Spinning Pinwheel.
    Hopefully this will resolve the problem!
     
  14. Giuly, Feb 21, 2013
    Last edited: Feb 22, 2013

    macrumors 68040

    Giuly

    #14
    mds = hard drive indexing for Spotlight. Look at the top right of the screen, there should be a dot in the loupe. Click it and it'll tell you when it's done. A full indexing only takes place when you attach a new volume.

    Ah, you've figured that out already.
     
  15. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #15
    .DS_Store files are not part of the problem and deleting them only means the system will recreate them.
    PRAM/NVRAM has nothing to do indexing issues. Resetting it will not help.

    If a drive is constantly active or your CPU utilization is high (possibly with increased temps and fan speed) when you're not running any major apps, you can check to see if Spotlight is indexing by looking at the Menu Bar icon:
    [​IMG] (not indexing)
    [​IMG] (indexing) (pulsing dot)​
    When it's indexing, you may also see increased CPU and RAM usage by the mds and mdworker processes in Activity Monitor.

    To re-index your drive:
    If that fails to index, enter the following command in Terminal:
    sudo mdutil -i on "/Volumes/your drive name"​
     
  16. macrumors 6502

    Joined:
    Feb 7, 2013
    #16
    How I told him to reindex his drives works perfectly well.
     
  17. macrumors regular

    Joined:
    Oct 11, 2012
    #17
    Hmmm ... thinking this might be my issue ... seems like the dotted icon for spotlight is constantly popping up despite no real change day to day ...

    Might do the procedure myself now
     
  18. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #18
    I didn't say the part of the post which refers to reindexing doesn't work. In fact, that procedure is in the link I posted. I only addressed the fact that the .DS_Store files are not part of the problem.
     
  19. thread starter macrumors member

    Joined:
    Jan 14, 2013
    #19
    It happened again this morning, so I ended up re-installing OSX in recovery. I did the re-indexing procedure last night and it didn't seem to help.
     
  20. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #20
    Just be aware that the initial indexing process could take several hours, so let it finish. After it's done, maintaining the index will be done in the background and you likely won't even notice it.
     
  21. thread starter macrumors member

    Joined:
    Jan 14, 2013
    #21
    I went ahead and did the re-indexing procedure after the OSX recovery, just for good measure. I'm leaving it run while I go run errands.
     
  22. thread starter macrumors member

    Joined:
    Jan 14, 2013
    #22
    So far, so good. I've been running games and surfing around for a few hours now and no SPOD!
    I'm glad it seems as though this is fixed now. I was really starting to worry...
     
  23. thread starter macrumors member

    Joined:
    Jan 14, 2013
    #23
    After I reinstalled OSX, it ran good for a while, then after I loaded back up my programs, it started SPOD'ing worse than before. I broke down and called Apple Support, since it's still within the first 90 days of my purchase. They helped me clean out the start-up programs, which solved the issue.

    Upon starting them up one by one, I found out that CrashPlan's software was causing the issue!

    It's a shame, because the software has worked well for backing up my iMac until I can cough up the dough for a Time Capsule.

    I'm going to contact CrashPlan about it and see what they say.
     
  24. macrumors member

    RebornTheGame

    Joined:
    Jun 1, 2012
    Location:
    Qld, Australia
    #24
    Let us know what they say. I was thinking of using CrashPlan to supplement my local TC backup, so it would be good to hear what they say.
     
  25. macrumors newbie

    Joined:
    Mar 5, 2009
    Location:
    South Australia ( it's a State )
    #25
    So refreshing to see some one

    A) fight a problem, to the death

    B) and win !!
     

Share This Page