New IOS update is eating my battery

Discussion in 'iPhone' started by mafpolo, May 14, 2012.

  1. macrumors member

    Joined:
    Feb 13, 2010
    #1
    Can't make it an entire day anymore, and that's been with two LOW ACTIVITY days so far.

    Anybody else having this issue?:mad:
     
  2. macrumors regular

    Joined:
    Dec 22, 2011
    #2
    The 5.1.1 right.
     
  3. macrumors 6502

    Joined:
    Apr 11, 2012
    #3
    You should restore it in iTunes, if you haven't already. I experienced the same when upgrading to 5.0, it could not hold for a few hours even.
     
  4. macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #4
    Nope. It's just you.

    Restore as new via iTunes(not from a back up), turn off all system location services except for Cell Network Search, turn off diagnostics and usage, set brightness to less than 50%, and turn off auto brightness.
     
  5. macrumors G3

    Apple fanboy

    Joined:
    Feb 21, 2012
    Location:
    Behind the lens, UK
    #5
    You don't mention which iPhone you are using. No change on my iPhone 4 since update.
     
  6. macrumors demi-god

    AustinIllini

    Joined:
    Oct 20, 2011
    Location:
    Austin, TX
    #6
    My iPhone 4's battery life has been fantastic since the update. Restore
     
  7. thread starter macrumors member

    Joined:
    Feb 13, 2010
    #7
    Yep 4S with IOS 5.1.1

    I am comparing the battery life pre update...so it should be giving me similar battery life without having to turn off bluetooth, turn off auto brightness, etc.

    I'm not meaning to be a jackass, but it will definitely improve if I just turn off the phone. I'm just frustrated, and I can't reset it on iTunes until I get home (I am traveling).

    I did go ahead and set up a Genius appointment, but I will do the reset before I go in. Also, the battery gets warm as it charges...never did that before.

    Why have I not learned my lesson, and waited for a while before I upgrade Apple software....

    :mad:
     
  8. macrumors 68040

    Roessnakhan

    Joined:
    Sep 16, 2007
    Location:
    Albuquerque, USA
    #8
    I was traveling too when I updated to 5.1.1, and I feel the battery drained faster than before. I'll have to do a restore sometime this week, I guess.
     
  9. macrumors member

    Joined:
    Jul 14, 2010
    #9
    Same problem. And I just restored as new.
    I'm goin to drain and see what happens. The battery on the 4s has been so bad for me.

    I wish I could get an iPhone that would just last me a day and I didn't have to turn crap off.
     
  10. macrumors 6502

    Joined:
    Oct 8, 2008
    #10
    Mine seems to be draining faster then normal too. Normal usage, backlight set to half brightness, blah, blah, blah. Can't get normal days use. :mad:
     
  11. macrumors regular

    Joined:
    Dec 22, 2011
    #11
    Great thread.
     
  12. macrumors member

    Joined:
    Jul 14, 2010
    #12
    I don't think the thread is bad. It just sucks that the phone actually can't last a full day for some of us.

    I truly envy the people that post 7hrs of good actual usage.
     
  13. macrumors newbie

    Joined:
    May 14, 2012
    #13
    Never met that problem.
     
  14. macrumors demi-god

    Gav2k

    Joined:
    Jul 24, 2009
    #14
    I'm suffering the same issue after a clean install with no restore! Safari is laggy too!
     
  15. macrumors regular

    Joined:
    Dec 22, 2011
    #15
    Pc me too make me want to throw my phone across a lake lol.
     
  16. macrumors member

    ali9686

    Joined:
    Jun 21, 2010
    #16
    +1
     
  17. macrumors 65816

    Joined:
    Aug 10, 2010
    #17
    Sorry but what kind of mental giant upgrades when they're traveling?
     
  18. macrumors 6502a

    Joined:
    Mar 9, 2012
    Location:
    United Federation of Planets
    #18
    Losing 15% battery overnight with 5.1.1 on 4S with no apps running. Was losing 1-2% on 5.1.
    Upgraded using dfu restore. All setings the same. Location off, bluetooth off, siri off, email manual.
    Did anyone try rolling back to 5.1.
     
  19. thread starter macrumors member

    Joined:
    Feb 13, 2010
    #19
    Upgraded before I left

    I'm no mental genius, but I updated before I left. If I was a mental genius, I would have waited a good while until the bugs were gone before restoring in the first place.
    :rolleyes:
     

Share This Page