New MacBook Air slow to shut down...

Discussion in 'MacBook Air' started by Drew017, Dec 29, 2012.

  1. macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #1
    I just got my MacBookAir (11 inch, early 2012) today and I'm very pleased with it, however it seems to take a while to shut down (like 20 seconds or so, instead of like 2-3) I know from using other MacBook airs that this doesn't seem quite normal. What could the issue be? I'm running OS X 10.8.2 (with the latest software updates) Thanks!!
     
  2. macrumors 601

    Joined:
    Aug 27, 2012
    #2
    External-attached devices incl USB, monitor and LAN shares will cause this delay. I suppose u can manually eject them before hand but that's the reason.
     
  3. thread starter macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #3
    Thanks, but nope... nothing is attached. It does this even when I have no apps running in the background :/
     
  4. macrumors 6502a

    Blaine

    Joined:
    Dec 3, 2007
    Location:
    Abilene TX
    #4
    I believe it's a known issue with 10.8.2

    Maybe it'll be fixed with 10.8.3
     
  5. thread starter macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #5
    hopefully! :p
     
  6. macrumors demi-god

    Joined:
    Oct 14, 2005
    Location:
    Virginia Beach
    #6
    x2, as I'm having it also! :D
     
  7. thread starter macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #7
    hmmmm if I repair permissions before I shut down it is normal, but when I restart it again it is back to the same old slow startup :confused:
     
  8. macrumors 6502

    Joined:
    Apr 8, 2010
    #8
    Choose Apple menu > System Preferences, click Startup Disk, and select a disk

    that you boot from
     
  9. macrumors demi-god

    Joined:
    Oct 14, 2005
    Location:
    Virginia Beach
    #9
    From reading various posts over the last few weeks, it seems like a lot of people are having this problem, and I don't think anyone's found a reasonable (i.e. not dicking around in terminal) workaround.
     
  10. macrumors 601

    Joined:
    Aug 27, 2012
    #10
    What about if u DONT SHUT IT DOWN, but merely put it to sleep like lots of people do? U know, go with the flow?
     
  11. macrumors 6502a

    Joined:
    Nov 4, 2012
    #11
    Because I like to shut my laptop down, I don't give a **** what other people do

    OP I'm experiencing the same thing, I noticed it right away the first time I shut it down. Hopefully it gets fixed some how
     
  12. macrumors 65816

    Joined:
    Jul 6, 2007
    #12
    I figured it out and it is easily repeatable. If you check that box to reopen everything when it restarts, it will take 10-20 seconds to shut down. If you uncheck the box, it'll only take a couple seconds because it doesn't have to save configuration.
     
  13. macrumors 601

    Joined:
    Aug 27, 2012
    #13

    Makes perfect sense. Also set sleep mode to 0, as detailed on past's posts.

    Lots of stressed out people on this forum! ^)
     
  14. thread starter macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #14
    its about the same for me here...idk
     
  15. macrumors 6502a

    Joined:
    Nov 4, 2012
    #15
    I read about this but people said it only worked the first time they shut down

    I tried it and it has worked a few times now so hopefully it continues to work! My shutdowns are instant while before it was a good 15-20 seconds
     
  16. macrumors 6502

    cedwhatev

    Joined:
    Oct 22, 2011
    Location:
    Canada
    #16
    This has been an issue with A LOT of people for the last few months, it seems to be an issue with 10.8.2. Every resolution has been attempted (deleting certain programs, fresh installations, SMC reset and so on..) and nothing seems to work. Fingers are crossed for 10.8.3 to fix it! :D
     
  17. macrumors member

    Joined:
    Apr 10, 2011
    #17
    All I can say about the possible fix in 10.8.3 is that the current 10.8.3 beta build 12D44 doesn't make any difference...
     
  18. macrumors 65816

    Joined:
    Jul 6, 2007
    #18
    I just tried this for the first time yesterday (was wondering if it would make a difference). Didn't know other people had reported on this but it makes sense other people would try too. :)
     
  19. macrumors 6502a

    Joined:
    Nov 4, 2012
    #19
    Unfortunately I spoke too soon, shut down last night after a few hours of use and it went back to taking 12-15 seconds. :(

    As others have said I don't think any "quick fix" will do the job here. Stupid Apple will just have to correct this on their own.
     
  20. macrumors member

    Joined:
    Jun 19, 2009
    #20
  21. thread starter macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #21
    here's the permissions that keep having to be repaired after every restart... I'm not sure how to keep them permanently fixed... any ideas? It shuts down normally if I repair these permissions, but i have to do it again before I shut it down again or I get the same old 15- 20 sec. delay :confused:
     

    Attached Files:

  22. thread starter macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #22
    submitted a bug report to apple through the feedback part of their letter... maybe I'll get a response :p
     
  23. macrumors member

    Joined:
    Dec 23, 2011
    #23
    I'm also getting this on my 2012 MBA 13". I submitted a bug report to Apple.
     
  24. macrumors 65816

    Joined:
    Nov 30, 2010
    #24
    Just curious, if you have configured the Mail app and it has lot of accounts?

    Next time quit the mail app completely and then do a shutdown and see if its faster.
     
  25. thread starter macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #25
    I only have my icloud email in it... and yeah I've tried it, but it still doesn't work :/
     

Share This Page