New MBA won't detect external display

Discussion in 'MacBook Air' started by xkmxkmxlmx, Jun 22, 2012.

  1. macrumors 6502a


    Apr 28, 2011
    I have had this issue for the past couple of days now and I can not figure it out.

    I received my new 2012 MBA last week. I imeediately popped in my mini displayport to hdmi cable to run a test video to my TV. Everything worked perfectly. Audio and video.

    About a week later, after getting my new desk and everything set up, I go and try again and I don't get the connection anymore.

    It won't show up in Display preferences and I can't "detect displays".

    The HDMI cable and adapter both seem to work just fine. I will have to wait until tomorrow to test at a friends house to make sure it is not either of them, but the reason I don't think so is that the MBA does in fact blink blue when I connect it, meaning that it sees something being connected to it. Also, my TV says "check source" when it is connected rather than "no signal" when not.

    Any help? Thanks!
  2. thread starter macrumors 6502a


    Apr 28, 2011
    Update: Still no fix. I have literally done everything I could possibly do. Searched every possible forum, etc. This is just so damn stupid. So tired of getting defective mac products. LG display looks like crap, my base is just as creaky as the 2011 and now it won't output video. I think it is time for a return.
  3. macrumors newbie


    Jul 10, 2015
    Did you try to smc and pram the machine?
  4. macrumors 68000

    Feb 21, 2012
    New Jersey Pine Barrens
    Did you notice that you're replying to a three year old thread? :)

Share This Page