new MBP: display dim and ichat mic problem

Discussion in 'MacBook Pro' started by lanturlu, Feb 7, 2007.

  1. lanturlu macrumors newbie

    Joined:
    Oct 1, 2006
    #1
    I bought a new 15" C2D MBP 2.33Ghz a couple of weeks ago, and I'm mostly satisfied with it. It had a G5 iMac 20" before that and I was happy with it too. However, I have two little annoying problems now with the MBP and I'd like to know if i'm the only one having these issues, and/or if anyone manage to solve them. Googling didn't help so far...

    1) Even though I unchecked the box for: Automatically reduce the brightness of the display before display sleep", the display still reduce it's brightness after something like 10 min of inactivity.

    2) Every time I make a video call with iChat, the (buildin) microphone is setting itself to something like ~75% "gain", which is WAY too low for anyone to hear in iChat (although it's fine for Skype). I see the change "live" by leaving the sound pref pane open with the mic at 100% and when I start an iChat call, it goes to ~75%. Pretty annoying!

    I did "repair permissions" several times, rebooted (yeah, an old reflex...) and tried to run my account with admin power (something I don't do normally) and it's all the same. Anyone has a suggestion, apart form getting used to the dimming of the display and using Skype instead of iChat for video calls?

    Thanks.
     
  2. iW00t macrumors 68040

    iW00t

    Joined:
    Nov 7, 2006
    Location:
    Defenders of Apple Guild
    #2
    I used to have that problem with my display dimming too, until I disabled the timed turning off the display under energy saver and away with the dimming too :)

    It might not work as it should, but I'll live.

    As an added bonus I get increased likelihood of my screen burning out prematurely so that I can get it replaced for a new screen under Applecare. A win-win in my book.
     
  3. amycishere macrumors 6502

    Joined:
    Feb 1, 2007
    #3
    I would think they'd see you changed the settings yourself...
     
  4. lanturlu thread starter macrumors newbie

    Joined:
    Oct 1, 2006
    #4
    I've confirmed with Apple tech support that these problems exists, although they don't refer to them as *problems*. iChat is setting the default mic volume at a predefined "acceptable" value at the beginning of every call (and during a call too if it was paused for a file transfer) and there is no way to tell iChat what should be that default value.

    And the screen dimming, as iW00t mentioned, preventing completely the display from going to sleep is apparently the only way to prevent the dimming, even though there seems to be an option to control it. Pretty silly!

    I wish there would be a way to just "put the display to sleep" on demand, like in a hot corner or at the push of a button. Tried to look for a way to do that but apparently it's not possible. Anyone know if it's possible ? I'm not talking about manually setting the time before display sleep to 1 min every time I want that feature, unless it automatically goes back to "never put it to sleep" once the display wakes up.
     

Share This Page