New PowerBook - Charging Problems

Discussion in 'Macintosh Computers' started by joseph_68, May 25, 2004.

  1. macrumors member

    Apr 8, 2004
    I just got my new 1.33 GHz, 15" PB (with the 5400 RPM drive option). It has been working fine, but today it refused to recognize the power adapter was plugged in. I made sure that the plug was "live" and all that. The adapter's "ring" would not light up. I reset the PB power manager, still no luck. Finally I took the adapter to a friend's house and it worked on his Mac. In almost total dispair, I came back to my home office, plugged it into my PB and then it worked!??? Has anyone got a clue as to what is up? Might it be the adapter has a short or a problem with my new Mac that I should be concerned about? Any input would be much appreciated! :confused:
  2. macrumors 65816


    Jan 2, 2004
    The Northlands
    I've experienced this as well. In addition, when the powerbook is plugged in the battery goes down 1% every few days, so I have to unplug it and recharge it to 99%.
  3. macrumors member

    Oct 3, 2003
    The adapter has a surge protection circuit. It shuts down if there's a surge.

    There's an apple help doc on this issue at

    From past experiences you may need to plug and then replug your adapter a few times to reset the circuit
  4. macrumors regular

    Jan 26, 2004
    Also, always plug the adapter into the wall before plugging the DC into your PowerBook.
  5. thread starter macrumors member

    Apr 8, 2004

    Thank you so much for the info. I feel much better now. I didn't want to worry that my logic board is bad!


Share This Page