Newbie Help: F1 key and brightness

Discussion in 'Buying Tips, Advice and Discussion (archive)' started by mcs37, Jul 27, 2004.

  1. mcs37 macrumors regular

    mcs37

    Joined:
    Mar 2, 2003
    Location:
    Washington, DC
    #1
    I'm trying to lower the brightness on my 12" PowerBook Rev C but the F1 key isn't doing it. When I hit F2, it shows the brightness icon and that it's at max. However F1 does nothing.

    I'm a newbie so I haven't figured out exactly how to check that the key is working correctly. I went to System Preferences and dug around to see if something had overidden the key but so far nothing showed up.

    Does anyone know how I can remap the F1 key so it will lower the brightness of the monitor? I'm writing this in the dark so it's like staring into a lightbulb. Not that I don't like the brightness of the LCD, but not at the moment...
     
  2. JzzTrump22 macrumors 65816

    Joined:
    Apr 13, 2004
    Location:
    New York
    #2
    Go to system preferences ---> Display By the bottom should be a bar that you could move a slider back and fourth. There ya go.
     
  3. mcs37 thread starter macrumors regular

    mcs37

    Joined:
    Mar 2, 2003
    Location:
    Washington, DC
    #3
    Cool, that works, so thank you, but I still can't figure out why the F1 key isn't doing the job for me. Where can I re-map they key?
     
  4. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #4
    Just out of curiousity, try this:

    Go to System Preferences...->International->Input Menu

    Make sure that Keyboard Viewer is selected (should be near the top of the list).

    Select "Show input menu in menu bar".

    Go to your menu bar and select the input menu and pull it down to select "Show Keyboard Viewer".

    Now you should see each key press in the viewer. Press F1 and see if it's even being registered as a keypress.

    Let us know what happens....
     
  5. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #5
    Darn it...

    That won't work. When I press F14 and F15 - the bightness controls for my G5 - they don't show up. So I wouldn't know if the key was working or not. However, all the non-mapped keys show up as being pressed (i.e., for me, F1-F8, F13, F16), so I guess, if F1 does show as being pressed, it means it isn't mapped to brightness control anymore. Sort of the opposite of what I said above....
     
  6. KevRC4130 macrumors 6502

    Joined:
    Jul 1, 2004
    Location:
    Massachusetts
    #6
    I didn't even see that F1 adjusted the brightness, so I tried it myself. At first, mine didnt work either. Once I tried pushing it slowly and firmly it worked. Make sure you are pushing it straight, and all the way down, and hold it a little longer than you might normally think. Hope this helps.
     
  7. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #7
    Work-around (yes, there is a way to see if the system sees the key press!):

    Keep the Keyboard Viewer open.

    Go to System Preferences...->Keyboard & Mouse->Keyboard Shortcuts.

    Click on the '+' button to add one (after making sure F1 isn't on the list of shortcuts already.... although ^F1 might be).

    After clicking the '+', don't bother selecting an application or menu title. Just go to the Keybaord Shortcut area and press the F1 key - it should show as a press in "Keyboard Viewer". Hit 'Cancel' to not add anything.

    This should show the key press - you can try it with F2 to verify.
     
  8. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #8
    I don't know - that sounds like a bad keyboard. My G5, iMac, and 1999 G3 PB all show immediate results - and the PB uses F1 and F2 also.

    And the 1999 PB is a lot slower than your PB's!
     
  9. mcs37 thread starter macrumors regular

    mcs37

    Joined:
    Mar 2, 2003
    Location:
    Washington, DC
    #9
    That works! Thanks. I didn't realize the key was so insensitive. :)
     

Share This Page