newbie iTunes question

Discussion in 'Mac Apps and Mac App Store' started by davrouk, May 18, 2003.

  1. davrouk Guest

    #1
    After I have imported a CD to the library, I create a playlist from all the albums tracks. However, when the playlist is created, the order of the tracks is alphabetical and not the order they were in on the CD.

    Is there any way to get iTunes to import the CD tracks and preserve the order they were in on the CD. I regularly listen to full albums, and this is not possible at the moment without a lot of time consuming re-ordering manually.

    :)
     
  2. WinterMute Moderator emeritus

    WinterMute

    Joined:
    Jan 19, 2003
    Location:
    London, England
    #2
    In the Import menu of the preferences is a check box that says: Add number to filename. Or something like that, it does just what it says, and your tracks will order by the number.
     
  3. King Cobra macrumors 603

    Joined:
    Mar 2, 2002
    #3
    In each created manual playlist (push the plus sign in iTunes) there is a tab on the left side of the main window, which lists numbers 1, 2, 3, 4, 5, etc. with your accompanying tracks. Click it.
     
  4. davrouk thread starter Guest

    #4
    Sorry phrased the question badly. I can do this for importing CD's no problem as described above (cheers for the help anyway guys)

    The problem is when I import a folder of mp3's I ripped on my wintel computer and copied over to the iMac. These files are named in the same way iTunes names the mp3s (ie 01 TrackName.mp3). I import them into the library and they appear in the library by artist/album.

    When i select all the files from the album in the library view and drag them into a new playlist, they order alphabetically, not by numerically / filename. Is there any way to do this, other than importing the original CD again (ive got loads so it will take me ages!)
     
  5. MacBandit macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #5
    Go to the edit menu then down to view options. Turn on 'Track Number' it's second from the bottom on the right row. You will then want to select that in the playlist or library menu.
     
  6. davrouk thread starter Guest

  7. MacBandit macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #7
    No problem at all. If you have any other questions about anything Mac related don't hesitate to give me a shout.
     
  8. globalwidget macrumors newbie

    Joined:
    Apr 17, 2002
    #8
    Don't even need to view track #'s

    You don't need to activate the 'View Track #' in the options area. If you click on the column header for any column where the playlists info for each track is identical such as Album Name, or Artist, the playlist will sort by Track #. Handy if you don't want to look at the rather superfolous Track # header.
     
  9. MacBandit macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #9
    Re: Don't even need to view track #'s

    Yes, that's true but it doesn't let you know what track number you are on unless you turn it on in view options.
     
  10. davrouk thread starter Guest

    #10
    Few more problems encountered:

    1. When I try to import mp3 tracks using the file...import menu, all tracks are greyed out and will not let me import - i can still drag the tracks from the original finder folder to the iTunes application window library - but the import menu option file chooser does not work!

    2. When I drag mp3 files in they are file named "01 Trackname.mp3' , but iTunes is removing the track number from the filename when copying the file to the iTunes directory. I have got "create files with track number" turned on in the iTunes import preferences.

    Any help sincerley appreciated (as usual)
     
  11. MacBandit macrumors 604

    MacBandit

    Joined:
    Aug 9, 2002
    Location:
    Springfield, OR (Home of the Simpsons)
    #11
    Okay here we go.

    1. The import option is used for simply that importing files of a different format into MP3. What I think you want to do is use the add to library option. The importing method is set in the preferences under 'importing'.


    2. Here you're getting confused between the filename (the name used in the finder) and the song title (the name used in the ID3 tags). The file name created does have or should have the track number in it in the music folder in the finder. There is no direct way to have the track number put into the song title in the ID3 tag. This is because it isn't really necessary since the ID3 tag tracks the track number separately.
     

Share This Page