newish 1.2 iBook trackpad/airport problem

Discussion in 'Macintosh Computers' started by California, Sep 11, 2005.

  1. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #1
    I was so happy with the 1.33 14' ibook that i got one for my biz partner; albeit a 1.2ghz 14" model. Barely used, with Apple Care for two more years. So screen is great, minimal plastic scuffing, I mean minimal, but something's weird with the trackpad . It takes way more pressure to push down than the 1.33's identical trackpad. And I notice it is sort of askew in its position on the palmrest. it also has a hollow sound. It bothers me because it seems somewhat unresponsive compared to the 1.33 and I did up the settings to fastest on trackpad and keyboard as done with my machine.

    Other thing, is I can't seem to get on airport.

    Maybe this is a panther update problem? As in something's screwy with the mechanics of the machine because I can't update to 10.3.9?

    Anyone got anything on this ibook trackpad or airport issue? Thanks
     
  2. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Check the System Profiler to make sure it does actually have an AirPort card. I'm not sure if they were standard on the 1.2GHz 14 inch iBooks but even so, it could have been taken out and sold separately.

    As for the track pad, maybe it's just seen more wear and tear than your new one so it's less responsive.
     
  3. thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #3
    "As for the track pad, maybe it's just seen more wear and tear than your new one so it's less responsive."


    Thanks MadJew, but took the 1.2ghz iBook into an Apple tech today and he agreed with me that there was something stuck in the trackpad. Really not from overuse or use. Will get a new palmrest/trackpad from Apple under Apple care. Am also upgrading hd to 5400rpm and going to Superdrive while the machine is taken apart... scary how much work an iBook is to take apart so might as well try to upgrade with the new palmrest/topcase.
     
  4. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Happy it's all working now. Yeah, you're right, may as well get as much done while the lid's off as possible. :)
     
  5. thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #5
    Oh yeah and I did an erase and full new install with my 1.33 discs on the 1.2 ibook with all 10.3.9 updates (still weirded out by Tiger) and no more airport troubles. Can't wait to get the 1.2 back.
     
  6. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Awesome. So it's all working perfectly now then? :)
     
  7. thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #7
    Yes; in the shop but working. That trackpad thing was strange...
     

Share This Page