Nexus 5 Bluetooth Problems - Car Audio

Discussion in 'Alternatives to iOS and iOS Devices' started by radus, Dec 18, 2013.

  1. macrumors member

    Joined:
    Jan 12, 2009
    #1
    hello I have massive problems pairing my Nexus 5 to the BMW Bluetooth module - it pretends to pair but stays in "Please Wait"

    Is there anybody here without "bluetooth problems"?

    had to switch back to the iphone 5s because of this ! (iphone 4 , iphone 5, xperia zl, iphone 5s are pairing remarkable good...)
     
  2. macrumors G3

    mattopotamus

    Joined:
    Jun 12, 2012
    #2
    Mine works fine. Are you pairing when you first start your car? I know a lot of cars will only pair within the first few seconds and if no device is connected it will auto shut off.
     
  3. macrumors 68030

    Lloydbm41

    Joined:
    Oct 17, 2013
    Location:
    Central California
    #3
    No problems pairing my Nexus 5 with Ford Focus, Chevy Volt, wireless headsets, wireless BT speakers or anything else. Works perfectly with everything.

    Are you stock or using a ROM? Have you made any changes to the phone at all?
     
  4. thread starter macrumors member

    Joined:
    Jan 12, 2009
    #4
    stock android, pairing procedure as BMW wants it

    thanks for your help!

    I use stock android (now 4.4.2) - there are no problems using a bt-headset, but pairing with the cars bluetooth just does not work (beginning from the cold), the cars bluetooth works flawlessy with iPhones and Sony xperia zl (Android 4.2.2)
     
  5. macrumors 68030

    Lloydbm41

    Joined:
    Oct 17, 2013
    Location:
    Central California
    #5
    Sounds like an a2dp issue. Clear all of your BT connections from your nexus 5. Reboot nexus 5. Start your car and go into phone pairing mode. Start BT on your nexus and then click search for devices. You should now see your car and the car should reset its display to match pin numbers with your phone.
     
  6. macrumors G3

    mattopotamus

    Joined:
    Jun 12, 2012
    #6
    I did have an issue that started this Monday out of nowhere. Every time my phone would pair it would auto launch google music (I have audio off under the paired settings). The only way I was able to fix it was to disable google play music totally.
     
  7. thread starter macrumors member

    Joined:
    Jan 12, 2009
    #7
    --> Lloydbm41

    that is what I did - I even deleted all the car’s connectiones, rebooted the nexus 5, enabled ART (as the last trial) … did not work, the phone is able to find the car and I can enter the car’s bt-passkey … and then “Plaese wait” … for ever
     
  8. macrumors 6502a

    Joined:
    Feb 4, 2012
    #8
    You have a Chevy volt? I love that car! My favorite electric car, I despise pretty much any electric car other then that, how do you like it and I only came here because I'm getting a nexus 5 and I strictly use Bluetooth when I'm in my car
     
  9. macrumors 68030

    Lloydbm41

    Joined:
    Oct 17, 2013
    Location:
    Central California
    #9
    Chevy Volt is probably my favorite car I have ever owned in my nearly 3 decades of driving. Not because it is the most luxurious or the fastest or the best looking, but all around it is just a fun a little car. And the fact that I go on average 1200 miles before needing gas... and it only costs $33 here in California to fill up (on Premium!) Electric cost is roughly $35 a month on your home electric bill. In California, you can get special rates for home electric if you own the Volt. And the $7500 I got back on my tax return from the Federal government was quite nice!

    Anyway, I have no issues connecting my Nexus 5 or previously my Nexus 4 or Nexus 7 to my Volt. It connects right up every time. Doesn't matter if I use a custom ROM or stock Android. Additionally, you can use your steering wheel controls to change tracks on Pandora, G Music and a couple other music players I have used. Calls are crystal clear and also controlled by the steering wheel controls.
     
  10. Vegastouch, Dec 19, 2013
    Last edited: Dec 19, 2013

    macrumors 601

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #10
    No issue. My Nexus 5 works better with my car (13 Nissan Altima) than my GS3 did. And you dont have to start the car to pair it. Just turn on to accesssaries so the bluetooth is on. There is no difference from that and starting it.
     
  11. macrumors 68040

    AutoUnion39

    Joined:
    Jun 21, 2010
    #11
    Do you have iDrive? What I usually do is delete the devices from both the car and phone. Then reboot phone. Then when you are search for devices, make sure to punch in the same pass-key for both (usually do 1111 or 0000).

    My 4.4 ROM (on my GS4) works perfectly with my BMW and Audi.
     
  12. thread starter macrumors member

    Joined:
    Jan 12, 2009
    #12
    its a 2005 e53 x5 without iDrive - may be i should by a new car, but it is nearly as good as a new one and i am the first owner.
    so i bought an iPhone 5s and use it all the day.

    in the evening i play half an hour with my Nexus 5 - I love it so - it is such a shame that i can not get it to work with the car's bluetooth
     
  13. macrumors newbie

    Joined:
    Dec 31, 2013
    #13
    Same issue

    I have a 2004 BMW X5 e53 without Nav, never had a problem pairing any phone but now Nexus 5 pairs ok with the car then drops the bluetooth connection 10 seconds later... All I want to do it use the car kit.
     
  14. macrumors 6502a

    Joined:
    Jul 30, 2008
    Location:
    Dublin/London
  15. macrumors newbie

    Joined:
    Dec 31, 2013
    #15
  16. macrumors 6502a

    Joined:
    Feb 6, 2013
    #16
    I have issues with my car not seeing all my contacts on the Nexus 5. :(
     
  17. macrumors 68000

    daveathall

    Joined:
    Aug 6, 2010
    Location:
    North Yorkshire
  18. macrumors 601

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #18
    Has to be your car. My Nexus 5 works better with my car than my GS3 did in that respect. Could be thebphone i guess. I dont really kow why my car wouldnt remember my contacts w/ the GS3 but does w/ my Nexus.
     
  19. thread starter macrumors member

    Joined:
    Jan 12, 2009
    #19
    it was the car

    the nexus 5 works perfectly with a friends Porsche PCM 3.1 ...
     
  20. macrumors 6502a

    Joined:
    Feb 6, 2013
    #20
    I thought that but it worked perfectly with iPhone 4 and 5S. :(
     

Share This Page