No Mouse in System preferences

Discussion in 'Mac OS X Lion (10.7)' started by nambuccaheadsau, Sep 8, 2011.

  1. macrumors regular

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #1
    Using OS X.7.1 and for some reason my wireless Mighty Mouse no longer has a Mouse pane in System Preferences, including under 'Show All'. Have tried disconnecting and setting up new connection with a wired mouse, but the Mouse pane does not appear.

    Any suggestions or looking at a clean install, please?
     
  2. macrumors 65816

    Joined:
    May 20, 2003
    #2
    Why do people insist on running to clean install every time they have a problem?

    Have you tried deleting the System Preference preferences and the mouse prefpane preferences?
     
  3. macrumors regular

    Joined:
    Jun 10, 2009
    #3
    Amen to that!

    OP: First, check if the preferences exist: /System/Library/PreferencePanes/

    If it's there, then it's likely a conflict with a config file (see response above). You can verify this by creating another user and signing into that account. If it's got a mouse.prefPane, then there is something in your user account. A format wouldn't help (unless you wipe your User data).
     
  4. nambuccaheadsau, Sep 8, 2011
    Last edited: Sep 8, 2011

    thread starter macrumors regular

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #4
    No Amen!

    And no mouse preference pane either, although all other preference panes are in order.
     
  5. macrumors regular

    Joined:
    Jun 10, 2009
    #5
    There you go. No reformat required.

    Either restore from backup or pull the preference pane out of a similar build. Peculiar why it was removed. You messing around with something?

    At least you know what file you need. Pretty simple fix.
     
  6. thread starter macrumors regular

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #6
    Fortunately had copied Lion installer to a thumb disk and simply run over top of OS X.7.1 and updated again.
     
  7. macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    #7
    Open System Preferences. Click and hold on the 'Show All' button and a list of preferences appears. At the bottom of the list, there is a 'Customize...' item that allows you to hide System Preferences using check boxes. This didn't exist in Snow Leopard. Maybe if you have "Mouse" checked, you could uncheck it to have it reappear.
     
  8. thread starter macrumors regular

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #8
    No Rob the Mouse pane was simply not there. Had tried the Show All and Customise.
     

Share This Page