iPhone No Notification Sounds

Discussion in 'Jailbreaks and iOS Hacks' started by LithePanther, Apr 20, 2013.

  1. macrumors 6502

    Joined:
    Sep 22, 2011
    #1
    Ok, so for the past few days I've been having some notification issues.

    For all the iOS stuff (Phone, texts, mail) the alerts come through, and some 3rd party apps (Tweetbot, WWF) also come through. But then I have a lot of other apps (CNN, ABC, Zynga Poker, Facebook) whose notification sounds don't come through.

    They all have sound enabled in the notifications list. I get the push notifications, I just don't get the sound. It's not muted because other notifications work.

    My tweaks are:

    Activator
    AskToCall
    Badge Customizer
    BiteSMS
    Blackout
    BrowseInApp
    BrowserChooser
    Calendar Pro for NC
    ChromeURL
    Cyntact
    DisplayCandy
    FolderEnhancer
    Gridlock
    ISX
    Jellylock
    Mail Enhancer Pro
    Multiiconmover
    Multistorey
    NCBettterSwipe
    QuickStore
    Springtomize 2
    SwipeShiftCaret
    ThumbsUp
    BatteryDoctorPro
    2x2 Folder Icons

    All the notification sounds work on my iPhone 4, and they worked on my iPhone until a few days ago.

    The only thing that changed since then was:

    Added: BrowserChooser, ChromeURL, Jellylock, Quickstore, and BatteryDoctorPro.

    Also, I installed Flusterless and used it for a day. Then I removed it. But i feel like the no sound started when I used flusterless to turn on DND (it is no longer on). I'm wondering if that might have corrupted any app that sent a notification while it was enabled?
     
  2. thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #2
    Bump. 600 views and nothing? You're hurting my feelings :(
     
  3. macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #3
    Silly question but any chance they somehow got disabled in settings>notifications?
     
  4. thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #4
    "They all have sound enabled in the notifications list."

    Everything is set up correctly. Which is why this is so baffling.

    I decided to uninstall and reinstall CNN to see if that might fix the issue. Instead, I think it isn't getting any push notifications at all (none in 6 hours) which is unusual for the time I've used the app but I have no way of seeing if they just didn't push anything today either.
     
  5. thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #5
    Anyone at all? I'm so desperate to fix this. I just bought the phone. I can't guarantee I can get another with 6.1.2
     
  6. macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #6
    I know that CNN doesn't make sounds by design. Same with Facebook for everything except private messages.
     
  7. LithePanther, Apr 20, 2013
    Last edited: Apr 20, 2013

    thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #7
    Every notification I got from CNN and FB dinged. I only get notifications from 8 apps and if some of them didn't ding I would have noticed right away. This was a new development
     
  8. macrumors newbie

    Joined:
    Mar 2, 2013
    Location:
    Australia
    #8
    Sounds like something changed the stock Messages sound (apps use this by default if they don't have their own sounds). Go to /System/Library/Audio/UISounds in iFile and make sure that sms-received1.caf exists and plays the sound when you tap it. If that works and you use WinterBoard, a theme has possibly overridden it with a silent sound - go to /Library/Themes and look through your themes for UISounds/sms-received1.caf; delete any that are silent. (It's also possible that a tweak is disabling it accidentally; if the above doesn't work, try uninstalling tweaks one by one until you find the culprit)
     
  9. macrumors regular

    Joined:
    Jun 23, 2010
    #9
    I'm having the same exact issue as lithepanther
     
  10. thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #10
    I don't use winterboard themes but i'll definetely check with iFile.

    I've already uninstalled all my tweaks

    My SMS DOES work though
     
  11. thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #11
    Any chance you've used flusterless?
     
  12. macrumors G3

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix, AZ USA
    #12
    Just a thought, and probably won't help at all, but have you tried cycling Do Not Disturb? As in turn it on, then back off?

    There are some battery saving tweaks out there that after removal often cause loss of cellular connection. Cycling the cellular button has restored the connection more than once. I'm applying that logic to this problem. Again, maybe not helpful but might be worth a shot if you haven't tried it already.
     
  13. thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #13
    I'll try it. Would you think installing flusterless and using that would also be something to try?
     
  14. macrumors G3

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix, AZ USA
    #14
    That would have been my next suggestion. If this does not work and you reinstall Flusterless and your sound comes back you know that the issue is with Flusterless.
     
  15. thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #15
    Sounds like a plan
     
  16. thread starter macrumors 6502

    Joined:
    Sep 22, 2011
    #16
    Didn't seem to help any. Tried multiple times.
     
  17. macrumors G3

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix, AZ USA
    #17
    Sorry, that was my shot at it. Don't know what else to suggest.
     
  18. macrumors 6502a

    Joined:
    Jul 3, 2010
    #18
    I also have this problem with certain apps like draw something and Facebook. They have the option for playing sounds when receiving notifications, that option is enabled, but I never actually get a sound played when I get a notification.

    I've never been able to figure out why and its very annoying.
     

Share This Page