iPad mini No persistent wifi during sleep on iPad mini??

Discussion in 'iPad' started by xraydoc, Nov 9, 2012.

  1. macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #1
    Purchased an iPad mini yesterday (black 64GB wifi). It appears, unlike my iPad 3, that the mini disconnects its wifi connection when put to sleep. Email doesn't come in until I open the Smart Cover and I see the wifi indicator turn back on.

    This is NOT the behavior of my iPad 3 (or my other two iPads before that). They maintain a persistent wifi connection.

    Is this normal behavior? I hope not, because it might be a deal-breaker for me.
     
  2. macrumors newbie

    Joined:
    Nov 9, 2012
    #2
    Interesting, I've got to test it out on mine and report back.
     
  3. macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #3
    Sorry, you're wrong. All iPads of the past: 1,2,3 etc and all versions of iOS 4,5,6 etc disable WIFI when in standby.
     
  4. macrumors 6502a

    Joined:
    Mar 13, 2012
    #4
    Yep and that includes the iPhones.

    This is precisely why I chose the LTE version.
     
  5. thread starter macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #5
    Definitely NOT my experience at all. I reliably get notifications when on wifi (cellular off) on my iPad 3. The iPhone 5, however, does seem to disable wifi in sleep. Persistent wifi for iPhones was an advertised feature of iOS 4.

    However, as the morning progresses, my iPad mini seems to be holding its wifi while in sleep (the email notification for replies to this post came in at same time as on my iPhone sitting right next to it). For now I'm chalking it up to dodgy wifi at my office and I'll continue to monitor for the day.

    But I will emphatically state that all 3 of my previous iPads have maintained persistent wifi connections during sleep. No question whatsoever.
     
  6. macrumors 6502a

    Joined:
    Mar 13, 2012
    #6
    The only time I have seen them hold a wifi connection is if they are plugged into a power source.

    The devices do connect and disconnect at random intervals, which is what you might be seeing. However, they are not stay constantly connected to WIFI.

    I have DDWRT on my router and can see the apple devices connecting and disconnecting.
     
  7. thread starter macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #7
    Then this is very strange. For the last 2.5 years I've had an iPad sitting next to me at work and at home, nearly 24/7, and my push emails and iMessages notifications sound off on my iPhone and iPad nearly simultaneously (sometimes give or take 10 seconds), regardless of being plugged in to the charger/Mac or not. And this is without cellular on the iPad turned on.

    I noticed it right away on my new mini because my phone was making the "new email" sound while the iPad mini was not.

    Could this be because my previous iPads were wifi+cellular models (even though cell is usually turned off and at one point not even subscribed to a service)?? The mini is my first wifi-only iPad. Might the two have different behavior when connected to wifi?

    It appears some of you don't want to believe that my previous iPads stayed connected to wifi when in lock mode, but 2.5 years of daily use tells me otherwise.

    (I will say however that my iPhone 5, unlike 4 and 4S, does seem to disconnect from wifi but at least that has LTE as backup).
     
  8. macrumors 6502a

    Joined:
    Mar 13, 2012
    #8
    Perhaps you had an app setup in a way that it was constantly using data and caused the connection to stay alive. However, this is not the norm.

    I can without a doubt say that on my iPhones and iPads, I will see the wireless bars connect within a few seconds of me turning on the screen.
     
  9. thread starter macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #9
    Not an app running daily on 3 different iPads, no (original, 2, 3).
    Again, perhaps there's a difference between how wifi connections are maintained on the 3G models, but I assure you I'm not imagining persistent wifi on my iPad 3. I'll even post a video if that what it takes.

    My wife's iPad 2 behaves same way - persistent wifi. It's a Verizon 3G model and the cellular has NEVER been activated on it.

    Regardless, it's sounding like this is normal behavior for the wifi-only iPad models if you're all saying the same thing. If that's the case, I'm afraid the iPad mini will have to go back. I was so looking forward to it. And I don't want to have to pay an extra $130 just to get persistent wifi.

    Beyond frustrating....
     
  10. macrumors 6502a

    ugcop

    Joined:
    Mar 15, 2012
    Location:
    Traveling @ Warp Speed ...... USA
    #10
    You are using Smart Cover on the mini. Are you using it on the other iPads?

    If not, remove the cover from the mini and problem solved.
     
  11. thread starter macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #11
    Yep. Smart Covers all around.

    This is very odd. I do not get my push email notifications on my iPad mini until I turn the screen on while they come in on my iPad 3 right away with screen off.

    So the rest of you are telling me that not receiving notifications on your iPads until you turn the screen on is normal operation? I can't emphasize enough how opposite this is to my experience (prior to the mini that is).

    **Anyone with a 3G/LTE iPad who can chime in? When cellular is off (on wifi only) and screen is off, do you receive email and other push notifications??
     
  12. macrumors newbie

    Joined:
    Mar 27, 2009
    #12
    I have a WiFi only iPad 3, but I definitely do get push notifications such as iMessages immediately, while the device is sleeping. Doesn't matter if the Smart Cover is on or not, or if it plugged in. If the Mini doesn't behave the same way, that would be an issue for me as well.
     
  13. macrumors regular

    Joined:
    Mar 19, 2006
    #13
    Connect to your network manually in your settings. I was having horrible issues with my Mini on my WiFi and this resolved all issues.
     
  14. thread starter macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #14
    Bingo.
    I sent myself an email and waited 20 minutes. Not a sound. Turn the screen on, wifi icon pops back up and email comes right in. Not normal behavior for my other iPads.
     
  15. macrumors member

    Joined:
    Mar 20, 2012
    #15
    I have just tested my mini and I am definitely getting emails and other notifications (e.g. eBay) with the mini off (as I do for the iPad 3).
     
  16. shady825, Nov 9, 2012
    Last edited: Nov 9, 2012

    macrumors 68000

    shady825

    Joined:
    Oct 8, 2008
    Location:
    Area 51
    #16
    iPad 3, Verizon LTE here.
    I think the problem is the smart cover.
    When I'm at home I always have it off. When I go out of the house I have it on.
    I leave for work pretty early so at night I get everything ready ahead of time.
    Ive noticed in the morning when I open my iPad I get all kinds of notifications popping in. BUT if the smart cover is off I will get them instantly. (even when screen is off)
    As you said, my iPhone and iPad will simultaneously chime together.

    I'm thinking it has to be related to the smart cover. :confused:


    *EDIT*
    Just tried a test email to myself. Now I'm getting the sound but the screen doesn't turn on. (smart cover off) weird..
     
  17. macrumors 68030

    kbmb

    Joined:
    Mar 13, 2007
    Location:
    NH
    #17
    Even if they drop the Wifi connection, I believe they are suppose to re-connect if you have email set to Fetch, not sure about Push.

    I've had a WiFi only iPad 2 since launch with a smart cover. I have my IMAP email set to check every 15 minutes. It has ALWAYS made the sound. Even with the smart cover on and the screen asleep.

    I got the iPad mini.....with the smart cover. Same thing, 2 email accounts set to check every 15 minutes and it works just fine.

    Are you doing push email? Maybe that's the difference. I don't use an iCloud email....all my accounts are IMAP.

    -Kevin
     
  18. macrumors 68030

    kbmb

    Joined:
    Mar 13, 2007
    Location:
    NH
    #18
    I've also been doing some testing and have my Airport Wireless Clients window open.

    I notice that my iPhone 5 WILL drop it's Wifi connection.

    However, the mini has yet to drop it, even with smart cover on and screen off.

    -Kevin
     
  19. macrumors member

    rahul247rocks

    Joined:
    May 18, 2012
    #19
    Are you using the Do Not Disturb Thing. And also check if your Email Settings is set to Push.
     
  20. Lobwedgephil, Nov 9, 2012
    Last edited: Nov 9, 2012

    macrumors 6502a

    Joined:
    Apr 7, 2012
    #20
    I have a wifi ipad 2, and it acts like your mini, don't get anything until I turn it on, my ipad 3 LTE gets everything in real time, even with cellular off. I do get push emails in real time, but my notifications don't sound on my wifi ipad until I turn it on.
     
  21. macrumors 68030

    kbmb

    Joined:
    Mar 13, 2007
    Location:
    NH
    #21
    Can people state whether their email accounts are Push or Fetch. There might be a difference in the way iOS handles the two when the device is sleeping.

    -Kevin
     
  22. macrumors member

    Joined:
    Nov 19, 2009
    #22
    My iPad mini gets mail pushed during sleep the same time as my iPhone, I can hear the notification sound almost simultaneously. I have a smart cover on it as well...it might be a setting on your iPad or a bad wifi connection?
     
  23. macrumors member

    Joined:
    Mar 20, 2012
    #23
    Mine is set to push on both devices, both with smart cover and both working as expected.
     
  24. macrumors 6502

    Joined:
    Mar 14, 2011
    #24
    I have both fetch and push mixed up on an iPad 2 and iPhone 4S. The push accounts notify me even if the devices are asleep, the fetch ones don't.
     
  25. macrumors 68030

    kbmb

    Joined:
    Mar 13, 2007
    Location:
    NH
    #25
    Do you have Fetch set to check or is it set to manual? Also, note that even if the main Fetch schedule is set, there is an advanced setting in Mail where each account can override it.

    Interesting that I'm the opposite....no Push and 2 Fetch accounts that work fine on iPad 2 and iPad mini.

    -Kevin
     

Share This Page