No Service with Tmobile on an Unlocked iPhone 4S At&T

Discussion in 'iPhone' started by Iceboie, Feb 6, 2013.

  1. macrumors member

    Joined:
    Aug 5, 2011
    #1
    I bought an used iPhone 4S At&t and unlocked it through one of those eBay seller a month ago. I restored the iPhone 4S through the iTunes software and it tells me Congratulations my my iPhone is unlocked. I installed a Tmobile micro SIM card in the iPhone, it searches for a signal and then it shows the dreadful No Service. When I change the settings from auto signal checker to manual, the Tmobile 3G is in the list that can be selected but still No Service. Last resort, I upgraded the firmware to 6.1 and jailbroke the iPhone 4S with the Evasi0n but it is still showing the big fat No Service message. Everything works flawless except the phone feature. Did I just bought an expensive iPod touch? Oh I also bought those Gevey S SIM card and that didn't work.
     
  2. Guest

    Joined:
    Jul 29, 2007
  3. macrumors 65816

    Joined:
    Mar 1, 2011
    #3
    Go to a T-Mobile store and have them assist you.
     
  4. macrumors 68040

    Joined:
    Aug 8, 2008
    Location:
    Manhattan
    #4
    How long did you wait after the "no service" message was displayed? When I unlocked mine and put in an active T-Mobile sim, mine displayed that message for about 30 seconds, then started searching and connected to T-mobile.
     
  5. macrumors 6502a

    chestvrg

    Joined:
    Dec 13, 2010
    Location:
    Miami, Florida
    #5
    Very strange as it sounds as if was not unlocked, by what you explained. If the SIM is active it should pick up some sort of signal whitin a minute.

    The other issue is that perhaps the SIM from tmobile has not been activated yet. As other users suggested, you should take it to tmobile and have them assist you.
     
  6. thread starter macrumors member

    Joined:
    Aug 5, 2011
    #6
    Thanks all, I will ask a Tmobile clerk during my lunch break today to see if they can assist me. I bought an activation micro SIM card kit from their website and I thought I already activated the SIM card and added 10 minutes of call time. I know that the iPhone is unlocked because if it isn't, then the iPhone will tell me that the Tmobile sim card is invalid and an error message will show up.
     
  7. macrumors 6502a

    Joined:
    Jul 12, 2004
    #7
    Sounds strange but did you try turning off 3G under the network settings? Something similar happened to my friend's unlocked iPhone and then it was able to connect to tmobile's towers.
     
  8. thread starter macrumors member

    Joined:
    Aug 5, 2011
    #8
    I just came back from the Tmobile store and they told me that the micro SIM card is activated, there are minutes on the account and concluded that my iPhone is still locked. Just great....sigh....
     
  9. macrumors regular

    Joined:
    Apr 10, 2008
    #9
    Might be worth a call to AT & T to see if they will officially unlock it for you. It takes them all of 2 minutes to process and once it is done you simply have to restore the phone in iTunes and you are all set.

    Might want to try restoring again with an ATT sim in there and see if that gets the unlock to go through
     
  10. macrumors 6502

    Joined:
    Sep 20, 2007

Share This Page