No SIM error on iPhone 3G

Discussion in 'iPhone Tips, Help and Troubleshooting' started by RustyM, Jul 12, 2008.

  1. macrumors regular


    Jun 8, 2004
    My iPhone 3G says I have no SIM card installed. And, of course, all phone operation isn't happening right now. Restarts aren't fixing it. Tried popping out the sim card and also syncing with iTunes. I'll head out to the apple store in an hour or so.

    Anyone else having this problem?
  2. macrumors regular

    Dec 14, 2007
    I had that problem with my 1st gen iPhone. I had to take out the sim, clean contacts and noticed the sim card was a little warped. I gently took the warp out of the sim by bending it a little and it has never done the error since.
  3. thread starter macrumors regular


    Jun 8, 2004
    Hey Hey! I just followed your advise. The sim wasn't warped, but I used a bit of spit shine to clean the contacts. It worked! Thanks Cudadown.
  4. macrumors newbie

    Jul 12, 2008
    this happened to me too. thanks for the tip. i didn't even think to check the sim...
  5. macrumors newbie

    Jul 13, 2008
    Hi you guys,

    I'm new around here, i had the same problem, found this solution, it's quite similar to the one suggested here, so i guess this is quite a popular problem. This is what i found -

    I hope i helped a bit,
    have a good weekend,
  6. macrumors newbie

    Jul 20, 2009
    had an actual problem with my SIM card

    I am an addict and could not wait to get to the store so I first tried resetting "network" and then "all" settings to no avail. After also tring to remove and replace the SIM card without that fixing the problem I decided to look at my actual SIM card for problems and when I did I found a tiny piece of something that was bridging the gap between two of the connector plates on the card. The gap is tiny but I saw it and removed it by brushing it away with my fingernail. When I inserted it back in the phone it came right up.

    Maybe I am lucky or maybe this was a real fix but worth looking at if you are having this issue I guess.

  7. macrumors newbie

    Dec 10, 2009
    I live in the SF Bay area, which has notoriously bad 3G network service, and my iPhone is about 9 months old. I went to sleep listening to music on my iPhone and woke up to the "No SIM installed" message.

    I'm in favor of starting with the least invasive solutions first, so I did a few hard reboots. It didn't work.

    I read about resetting network connections as a solution and was about to do that next when I read somewhere to try putting the phone into "Airplane Mode" and doing a hard reboot, then taking it off "Airplane Mode". THIS WORKED for me. As soon as I took it off "Airplane Mode" it redetected the network.
  8. macrumors regular

    Oct 27, 2008
    I had this problem and it wouldnt go away. It just randomly started happening the other day. I had the SIM tested by O2 and it was working fine so booked an appointment with an Apple Genius and they replaced the handset there and then - the genius thought the SIM reader may have been faulty.

    I dont know if maybe this is a larger problem and perhaps mine just died completely whereas others may just have temperamental SIM readers..
  9. macrumors newbie

    May 19, 2010
    cleaning my sim card off worked, but it still read "No SIM" until I turned airplane mode on then back off. fired right up away after that. yay

Share This Page