No sound on Doom 3, Please help!

Discussion in 'Games' started by dextertangocci, Jun 24, 2006.

  1. dextertangocci macrumors 68000

    Joined:
    Apr 2, 2006
    #1
    Hi everyone,

    Has anybody had this issue with the UB version of Doom 3? After I installed the Doom 3 1.3 Rev A update, the sound didn't work at all! It worked perfectly on my friend's iMac (BTW, it runs brilliantly on the 20" core duo with 1.5GB RAM, on Ultra settings), and not on my 2GHz MB, with 1GB RAM. Even when I connect external speakers or earphones to it, it doesn't work.:confused:

    Any help would be appreciated.
     
  2. BlizzardBomb macrumors 68030

    BlizzardBomb

    Joined:
    Jun 15, 2005
    Location:
    England
    #2
    This might sound a bit stupid, but have you checked the game settings?
     
  3. Striderdm1 macrumors regular

    Striderdm1

    Joined:
    Oct 24, 2003
    Location:
    England
    #3
    yea i used to suffer this now and then. I usually just rebooted and that did the trick even though i hated this as my mac could be up&running for months.. so i hated the reboot method, it seemed too Windows-like of a fix! lol

    But i did track it down to my web browser funnily enough. I cannot remember which one though, but it was either Safari or Camino. Basically, if i had been to a web site that played some sorta sound sometime, and i still had the browser running, then d3's sound would be silent. Sometimes with a little crackle! So now i make sure i've quit any browser first...

    I'm daft really, as running d3 is very demanding so i should really have quit all other apps anyhow for that extra tiny boost of speed! ;)

    I'm not saying this is your trouble, but perhaps there's something else that's hidden and not quit? Worth a shot... HTH?
    Strider
     
  4. dextertangocci thread starter macrumors 68000

    Joined:
    Apr 2, 2006
    #4
    Yup, but just one question, should I set it to stereo or surround for the MB's internal speakers? (BTW, neither option makes the sound world):(
     
  5. dextertangocci thread starter macrumors 68000

    Joined:
    Apr 2, 2006
    #5
    Now, the sound only works when I plug in external speakers or earphones:confused: :confused:

    And, to top it all off, when I use an external mouse, there is a stupid cursor in the middel of the screen while I'm playing, and it won't move:mad: My Wacon Graphire 4 pen tablet mouse can't even click:mad: I think the guy who wrote this update was drunk. I prefered it running under Rosetta.

    Does anyone else have these problems?????
     
  6. dextertangocci thread starter macrumors 68000

    Joined:
    Apr 2, 2006
    #6
    Does anyone know when they might release another update to fix these problems?
     

Share This Page