No sound on Mac after using Apple TV

Discussion in 'Apple TV and Home Theater' started by Snowden73, Jan 22, 2013.

  1. macrumors newbie

    Jan 21, 2013
    So I've got a 2010 Mac with AirParrot. I've used it with Apple TV and the last two times after I've turned off Apple TV and air parrot I've had no sound from my Mac. Tried fiddling with volume controls and making sure it's no longer mirroring or whatever but this time sounds not coming back. Anyone had a similar issue or any ideas what to do to fix it?
  2. macrumors 68000


    Mar 5, 2011
    Did you make sure your Output Device is 'internal speakers' and not 'Apple TV'?
  3. macrumors member

    Aug 12, 2011


    Open iTunes. Look in the Bottom right for an icon. This icon controls sound for your mac or apple tv. Just select your computer. Sorted.

    Yes, this caught me out, too.
  4. macrumors newbie

    Aug 2, 2012
    Cape Town, South Africa
    If you are running iTunes 11, the icon has moved to the top of the screen - next to the play button. Click on it and make sure that the local output is selected.
  5. thread starter macrumors newbie

    Jan 21, 2013
    Sadly it already has computer selected. Damn thought that would be it :(
  6. macrumors 6502


    Oct 24, 2009
    go to settings/audio/output ,make sure is on internal speakers.
  7. thread starter macrumors newbie

    Jan 21, 2013
  8. macrumors 6502

    Dec 12, 2009
    Calgary; Alberta; Canada
    I know that this thread is a bit old; but I had the same problem with my setup. Have a Atv 3 connected to a Samsung Tv. Streaming movies through my Mac would work; however, there was no sound; only video at the Tv. There was sound at my computer. If I played a movie through iTunes; everything would work as it should. If I tried streaming a movie through Xbmc; or played a movie through a third party player; I would get video; but no sound. I did a search for this problem and came up with several pages of different solutions; none of them worked. What I did try was; on the Atv 3; go into settings; Audio and Video and Output. Changed the setting from “Auto” to “16 Bit”. This worked for me! (For now).

    Just thought I would post this; just in case it may help someone out.
  9. macrumors 6502a

    Sep 4, 2012
    This happens to me too. I ended up just going to the volume icon in the upper right hand corner and turning it up. I guess you can say that I just deal with it.

Share This Page