No sound on my Mac Pro on Win XP Pro

Discussion in 'Windows, Linux & Others on the Mac' started by uelef, Aug 31, 2006.

  1. uelef macrumors member

    uelef

    Joined:
    Aug 7, 2004
    Location:
    Germany, Wuerzburg
    #1
    I finally succeeded in installing Win XP Pro on my mac pro - it was a hard struggle because the hard drives only used the PIO Mode. I tried all to change this - now I got it.
    It was one of the following two problems that made the workaround described in other threads not work:
    1. I only tried to install Win XP on a 100 GB partition on a Mac OS X hard drive.
    2. I installed Win XP with USB and Firewire hardware connected.
    Now I reinstalled XP on a own hard drive and without USB and Firewire hardware connected - and the hard drives now run fast in DMA mode.

    But I now got another problem. The audio hardware of the Mac Pro is not recognized. I installed the Mac driver CD two times. But the audio driver from Realtek is not loaded.
    I also tried to install the audio driver manually (using this link:
    http://www.realtek.com.tw/downloads...s=2004061&Software=True&title=HD Audio CODECs)
    but the installer says that the Microsoft Bus driver needs to be loaded...

    Any help from you?

    Ulf
     
  2. waremaster macrumors 6502

    Joined:
    Aug 27, 2006
    #2
    If you have installed the bootcamp drivers then do this.

    If you right click on My Computer then click on properties then click Hardware and then click Device manager you will see a section called System Devices.

    Scroll down and you will see a PCI Device with a ! on it.

    Double click on it and install the driver don't goto the internet let it search and it will find the drivers itself on your HD.

    Next goto Program Files and the Macintosh Drivers and then realtek and run setup.exe

    it will install the drivers then ask you to restart your machine. You will knotice you have sound even before it restarts :)
     
  3. uelef thread starter macrumors member

    uelef

    Joined:
    Aug 7, 2004
    Location:
    Germany, Wuerzburg
  4. waremaster macrumors 6502

    Joined:
    Aug 27, 2006
    #4

    No Problem. Glad to help.
     

Share This Page