No sound through HDMI

Discussion in 'Mac OS X Lion (10.7)' started by Sean-B-89, Jul 7, 2011.

  1. macrumors newbie

    Joined:
    Jul 7, 2011
    #1
    Hi all,
    I am using Mac OS X 10.7 Lion GM and everything is working like a charm, but I have found one bug that I got a problem with.

    If I connect my TV through the mini displayport, it does not pass through the sound like Snow Leopard does.

    If I go to the System Preference -> Sound I do not see the HDMI output anymore. What can I do about this? Does anyone else have trouble with this?

    I have upgraded straightly from 10.6.8 and am using the MacBook Pro 13inch 2011.

    Check the screenshot. Thanks!
     

    Attached Files:

  2. macrumors 6502a

    Joined:
    Apr 1, 2007
    #2
    Mini displayport doesn't have an audio channel simple.

    Use the 3,5" audio out with a jack or tos link.
     
  3. Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #3
    Recent Macs can output HDMI with audio via an appropriate MDP->HDMI adapter.
     
  4. macrumors member

    Joined:
    Jun 12, 2011
    #4
    Source: Wikipedia

    As for the problem, I will try this when I get home and post back.
     
  5. macrumors 6502a

    Joined:
    Apr 1, 2007
    #5
    Ah okay, seems like there isn't a cable from Apple for it though, but they point to third party ones: http://support.apple.com/kb/HT4241

    I've been using MDP -> DVI -> HDMI. Didn't know about this change.
     
  6. thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #6
    Yeah, well I am using an Minidisplay port-to-HDMI adaptor and, like I said earlier, with Mac OS 10.6 Snow Leopard it did work, but with Mac OS Lion is is not working anymore. I don't understand why it isn't working anymore :confused:

    It's like the Thunderbolt driver has changed and doesn't support the audio anymore..
     
  7. macrumors 6502a

    Joined:
    Apr 1, 2007
    #7
    Have you tried contacting the manufacturer? It might well be a hw/sw incompatibility given the OS update that hasn't been addressed by Apple yet so go for feedback with Apple if the manufacturer isn't able to help.
     
  8. macrumors 6502a

    runebinder

    Joined:
    Apr 2, 2009
    Location:
    Nottingham, UK
    #8
    Shouldn't be an issue, audio was added when they updated MDP to Vesa 1.2 standard, and as long as the adapter follows that (which in the OP's case it does as they could get audio in SL), then incompatibility isn't going to happen.

    Not a developer and waiting for the full release before installing Lion, hope this isn't an issue as I often hook my MBP up to our AV Receiver.
     
  9. thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #9
    Yes, I guess the only thing I can do it wait for the full/final version of Lion and hope the problem solves, right?
     
  10. macrumors regular

    Joined:
    Feb 13, 2007
    #10
    This is true. My girlfriend has the newest Macbook Pro 2011 and i have the 2010. Her's does the audio over the mini display port. Mine doesn't, at least not in Lion. The only reason why i know this is because i recently wanted to watch a movie with the cable she uses and i couldn't get the sound to come through. Is this because of Lion or because of the display port on my older computer?
     
  11. Mudman1948, Jul 20, 2011
    Last edited: Jul 20, 2011

    macrumors newbie

    Joined:
    Sep 21, 2007
    Location:
    Greenville, SC
    #11
    I just downloaded OS X Lion (the retail $29.99 version) today from the Mac App Store, and guess what I found out…*no audio through HDMI. This stinks. I just wanted to post here to show that it wasn't fixed or patched between the GM and final release version.

    WAIT WAIT WAIT

    I just checked a 2nd time (after restarting) and now the HDMI option is showing up. Weird. Sorry for the incorrect statement.
     
  12. macrumors member

    Joined:
    Jan 26, 2006
    #12
    Same boat

    I am in the same boat here. I upgraded to 10.7 and now sound over HDMI is not working anymore on my 2011 MBP 13". :(
     
  13. thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #13
    I heard that the GM was the same as the final. But I will also download OS X Lion and see if it indeed will work!
     
  14. thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #14
    Nope.. Even after installing Lion from the Mac App Store the HDMI sound option still won't come up! :confused:
     
  15. macrumors newbie

    Joined:
    Jul 22, 2011
    #15
    Same problem right here, iMac mid 2011. Video and audio got sent just fine to my home theatre under Snow Leopard. Since Lion no such luck.
    Have you tried SMC reset? I read that might help (may take 2-3 attempts), although it didn't for me.
    So now, should I just cross my fingers and hope that Apple follows up on bug reports? Anything else I can try?
     
  16. macrumors newbie

    Joined:
    Sep 2, 2008
    #16
    same problem with my MBP 2011 but for me my monitor comes up under system preferences > sound (output tab) as type:HDMI and when i chose it there is still no audio :( anyone have a fix yet? also i am using the moshi adapter too could this be the problem?
     
  17. macrumors 65816

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #17
    Everything works great here. Sound through mDP to HDMI cable and a beautiful FullHD picture on my Sony Bravia TV.

    This is the cable I am using on my 2011 15" MacBook Pro.
     
  18. macrumors member

    Trigeeks

    Joined:
    Nov 18, 2010
    #18
    Mine is not working with Lion either. That's just weird!!!!
     
  19. thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #19
    Yes I have tried that, but it didn't work. And I am not intended to buy another cable again..
    I've also replied to a topic on the Apple Discussions forum. Maybe we need to complain there to get their attention?

    https://discussions.apple.com/message/15693651#15693651
     
  20. macrumors newbie

    Joined:
    Jul 22, 2011
    #20
    Right, that's where I read it, thanks. Will keep my eye on that discussion. Sent a bug report as well, we'll see.
    Let's be realistic, the problem seems to be rather widespread, so if Apple wants to be in our living rooms delivering our home entertainment, they'll want their devices to work with our tv's an other receivers, right? Meanwhile, though, I'l be watching some good old-fashioned broadcast tv :)
     
  21. macrumors member

    Joined:
    Mar 25, 2011
    Location:
    London
    #21
    Have you tried holding down alt and clicking the volume icon to select another audio output? My 2010 Macbook pro works fine with 10.7 to both a TV and also to an amplifier using mini display port to HDMI adapter.
     
  22. macrumors newbie

    Joined:
    Jul 22, 2011
    #22
    Is there another (quick) way to switch between audio devices? :)
     
  23. macrumors newbie

    Joined:
    Jul 26, 2011
    #23
    When It finally does start working again (I'm having the same problem with 13"MBP 2011) Worked on Snow leopard,


    Use Sound source - Its free and has a menu bar icon to easily switch between inputs and outputs :)
     
  24. Sean-B-89, Jul 27, 2011
    Last edited: Jul 29, 2011

    thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #24
    Did no one got hands on the 10.7.2 developer's update to test the audio through hdmi by accident?
     
  25. macrumors 6502

    Madd the Sane

    Joined:
    Nov 8, 2010
    Location:
    Utah
    #25
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    File a bug report and wait for 10.7.1.
     

Share This Page