No sound via MDP suddenly

Discussion in 'MacBook Air' started by eternlgladiator, Sep 25, 2013.

  1. macrumors 68000

    eternlgladiator

    Joined:
    Jun 20, 2010
    Location:
    Twin Cities
    #1
    Hey everyone. I use my MBA to watch media on my tv and for a long time have used a MDP to HDMI cable that has worked great with my 2010 macbook pro, 2012 mini and up until recently with my 2011 macbook air (specs in sig). All the sudden it won't play any sound. I see the option for my TV in sound settings and have tried messing around a bit to get things to work as occasionally connectivity hurts it but now it's been about a week or so nothing has changed. Any ideas?
     
  2. macrumors 68000

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Sorry if I'm mentioning things you've already covered.

    -check the converter with your other Macs. If the issue persists with these, replace the MDP converter. It's all that can be the problem.
    -check the output is set to the TV in System Preferences>Sound
    -if the issue persists just on your MBA but sound works fine on other Macs, reset both the PRAM & SMC.
    -if resetting the SMC/PRAM doesn't work, ensure all software is up-to-date, then have the unit serviced by Apple.

    If you have any further queries, please quote this message so I'll get a notification. I'll be happy to help and I hope we can resolve your issue.

    Best wishes.
     
  3. thread starter macrumors 68000

    eternlgladiator

    Joined:
    Jun 20, 2010
    Location:
    Twin Cities
    #3
    Other macs are gone now. I've been swapping over the last year. I'll try the other things you mentioned. Thanks!
     
  4. macrumors 68000

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Do you possibly have any friends who have Macs you can use? It's just so we can establish the issue isn't with the adapter.
     
  5. thread starter macrumors 68000

    eternlgladiator

    Joined:
    Jun 20, 2010
    Location:
    Twin Cities
    #5
    I rebooted and reset pram and that did it. Thank you very much!
     

Share This Page