non-zero refcount error in new iPhone SDK?

Discussion in 'Mac Programming' started by ace2600, Mar 30, 2008.

  1. macrumors member

    Mar 16, 2008
    Austin, Texas
    Has anyone else been getting these errors in the console when running Xcode from Beta 2?
    3/30/08 11:47:05 PM Xcode[123] Unable to load platform at path /Developer/Platforms/Aspen.platform 
    3/30/08 11:47:06 PM Xcode[123] LCC Scroll Enhancer loaded 
    3/30/08 11:47:06 PM [0x0-0x19019][123] Xcode(123,0xb0103000) malloc: free_garbage: garbage ptr = 0x2b405a0, has non-zero refcount = 1
    3/30/08 11:47:06 PM [0x0-0x19019][123] Xcode(123,0xb0103000) malloc: free_garbage: garbage ptr = 0x2b71810, has non-zero refcount = 1 
    The non-zero refcount error then repeats itself a few times. I had assumed it was my program, but I created a new one from the template and ran that and received the same error. Perhaps it's the trying to load Aspen part, though I don't know why it's trying to load Aspen in the new SDK. Could be a manual setting?

    After awhile, I get this dreaded 10810 message.
  2. macrumors 68000


    Jun 9, 2004
    Rochester, NY
    Yea, I've been having the same problems (only after installing the iPhone SDK). It's a pretty widespread issue, but I don't think Apple has released any statements on the matter.

    I know it's Beta software and all, but there's no way that a Beta being released *to the public* for free download should cripple an entire operating system. :rolleyes:
  3. macrumors 65816


    Jun 3, 2007
    I think those are more memory management-related errors and messages in the beta 3.1 version of XCode that issues related to any applications specifically. Seems to be stuff generated by the garbage collector.

Share This Page