Not all Artists showing up on iPhone 4S music application

Discussion in 'iOS 5 and earlier' started by oneofthesedays, Dec 25, 2011.

  1. macrumors newbie

    Joined:
    Dec 25, 2011
    #1
    Strange bug. I can see all of my artists on iTunes on my PC, but for some reason they don't all show up on my iPhone when I try and view all of my artists in my music collection. If I search for the artist name on my iPhone they show up as I would expect, it's only when I try and display all artists that they refuse to show up.

    I've tried numerous things to fix this, re-synced my library every possible way, to no avail. Is this a fatal bug in iOS5 or does someone have a workaround?
     
  2. macrumors regular

    bgtrack

    Joined:
    Jun 6, 2011
    Location:
    East Lansing
    #2
    Are you syncing with match or straight from iTunes?
     
  3. thread starter macrumors newbie

    Joined:
    Dec 25, 2011
    #3
    iTunes
     
  4. macrumors regular

    bgtrack

    Joined:
    Jun 6, 2011
    Location:
    East Lansing
    #4
    Try taking the music off and then putting it on...if that doesn't work restore the firmware...it might be a bug in the software.
     
  5. macrumors member

    Epoch KW

    Joined:
    Dec 2, 2011
    #5
    It could be related to having created compilations of the albums the artist has performed on

    I've noticed that anything grouped as a compilation doesn't show in all contacts

    Jon
     
  6. macrumors 68000

    Joined:
    Feb 2, 2009
    #6
    'Get Info' in iTunes and check that the track info in 'Sorting' is identical to the track info in the 'Info' tab. I think 'Sorting' overrides 'Info'.
     

    Attached Files:

  7. macrumors regular

    Joined:
    Dec 13, 2011
    #7
    This is normal. If you want it to show up under Artist on your iPad, you will have to Get Info in iTunes and uncheck "Part of a compilation" on the Info tab.
     
  8. macrumors 6502a

    Joined:
    Sep 19, 2008
    #8
    This. I had the same problem.
     
  9. macrumors 68000

    Joined:
    Jun 5, 2009
    #9
    im having the same issue too, if I edit the artist name thru iTunes on my laptop, the edit wont show on the music app on the phone. It worked fine on iOS4, but both of my iPod touch and iPhone are having this issue
     
  10. macrumors newbie

    Joined:
    May 1, 2012
    #10
    Challenge accepted. Go to settings> music> turn off group by album artist. Success
     
  11. macrumors 65816

    adam044

    Joined:
    Jan 24, 2012
    Location:
    Boston
    #11
    Sweet worked forme! Mine were showing up as unknown all of a sudden. What does group by album artist even do
     
  12. macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #12
    Dude, you're a life saver! This was driving me nuts! Thanks!

    ----------

    Here's a pretty good thread on the explanation.
     
  13. Grumpy232, Jun 30, 2012
    Last edited: Jun 30, 2012

    macrumors member

    Joined:
    May 26, 2012
    #13
    went to settings>music>turn off group by album artist, and still no "artist" show up at all. What do I need to do to get "artist" to show up?

    Edit: ok, so the artist showed up, don't know how, but they did, oh well.
     

    Attached Files:

  14. macrumors newbie

    Joined:
    Jul 20, 2012
    #14
    Problem Solved!!

    It's from projecttimmy here: http://www.tested.com/forums/please-help/10160-artist-name-not-showing-up-on-iphone/

    Anyway, here's the fix!



    "Here's the stitch.

    If you're still having the problem, here is the solution.

    iTunes allows you to edit the ID3 tag, but for some reason if there isn't already a title tag in the song, the title tag for that song in itunes becomes the FILENAME not the title tag.

    What you have to do is, manually edit the title tag on your computer or with an external ID3 tagger software, the title tag IS NOT the file name.

    In windows you can do this by; Right clicking the song, clicking properties and clicking details.

    Make sure to have written the 'Title' and 'Album Artist' tags, the rest don't officially matter as you can change them later through iTunes. You can also change 'Album Artist' in iTunes, but do this before as a precaution.

    No idea on mac as I don't use one lol.

    Then upload to your iPod or iPhone, and it will be solved.

    I hope this helps anyone, I have musical OCD and this really pissed me off.

    Thanks.

    - Timmy "
     
  15. macrumors newbie

    Joined:
    Jul 31, 2012
    #15
    Epoch had it right :D

    Just go into Info on the songs in question (before loading into your iPhone) and uncheck "Part of a compilation".

    It worked for me and it's probably what's happening to most of you too!

    :):):)
     
  16. macrumors newbie

    Joined:
    Jan 16, 2013
    #16
    Worked for me!

    I have an ipod touch 5g, and this fixed the problem for me. Thanks!!
     

Share This Page