Now this is bizarre. ATV2 Flickering but not in XBMC

Discussion in 'Apple TV and Home Theater' started by hobx, Jan 22, 2011.

  1. macrumors regular

    Sep 6, 2010
    So, I've had an issue with the ATV2 since I got it. It flickers during what I can only presume is some sort of HDMI handshake procedure.

    It isn't like the negative image some people are getting. Its literally a split second black flicker and then back. Its intermittent and can sometimes be solved by swapping hdmi ports or cables, but not always. The cables and ports have all been tested on PS3 / XBOX and have no problems there.

    The issue also did not happen at first, it started about two weeks after I bought the ATV.

    Now....installed XMBC today and within the XMBC interface, everything is fine. No problems whatsoever. As soon as I drop back into the ATV interface, the problem returns.

    I was going to see if I could get a replacement, but now it looks like this is a software issue.

    Any advice or input from anyone? Anyone else got this problem?

    The TV is a Sony Bravia KDL-40W4000, which, again is not one of the models listed with the HDCP negative colour handshake issue....
  2. thread starter macrumors regular

    Sep 6, 2010
    Looks like I spoke too soon. The issue has now started showing up in xbmc too. Think I'll return it unless anyone has any ideas?
  3. macrumors 6502


    Jun 19, 2009
    The Waste
    I think this model has been known to have handshake issues with certain devices. If your tv is what the :apple:TV is having issues with, a new one may exhibit the very same issues. Nevertheless, it won't do any harm to try and get a new unit out of Apple. Just remember to un-jailbreak yourself before heading to the Apple store. If they see an XBMC sub-menu on your device all bets are off! Good luck!
  4. macrumors 68020


    Sep 20, 2004
    Have you tried connecting it to another TV to see if the problem persists?
  5. macrumors member

    Dec 3, 2007
    Same model of TV here, and same issue ... intermittent black flickering no matter what the source (menus, movies etc). Sometimes I've been able to resolve it by ensuring the TV is the last component to be switched on. Fingers crossed for an update from Apple, but if the issue is restricted to a small number of TV models I guess I shouldn't hold my breath ... :(

Share This Page