O M G !!! I need HELP FAST! (prefs gone)

Discussion in 'macOS' started by thumper, Feb 9, 2006.

  1. thumper macrumors 6502

    thumper

    Joined:
    Oct 25, 2003
    Location:
    Under the Sea
    #1
    i was installing an app and i guess i filled up my disk, it said
    i only had 300MB left...

    i opend safari and lots my Prefs!!!
    so i restarted and ive lost ALL Prefs for EVERYTHING!
    i have to enter SN for everything all over again!!

    is there anyway to recover my prefs?!?!

    please i beg for some input:(
     
  2. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #2
    Filling up you disk shouldn't cause you to start losing files. Maybe the application was a malicious one? Or maybe it just screwed up everything because of a bug?

    Did you do the typical file system maintenance stuff like repair permissions and fsck?
     
  3. thumper thread starter macrumors 6502

    thumper

    Joined:
    Oct 25, 2003
    Location:
    Under the Sea
    #3
    ill try that :)
    mac seems to run really fast now btw LOL
    ive got like 20 apps that i need to register again :(
     
  4. thumper thread starter macrumors 6502

    thumper

    Joined:
    Oct 25, 2003
    Location:
    Under the Sea
    #4
    Oh! my old User Folder was moved to my app folder!!!
    ... and osx made a new user with the same name thats all default!!!

    ?

    it wont let me copy my old User folder back :(
     
  5. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #5
    Yeah, that'd do it
    What were you installing, and/or what did you do immediately prior?

    Is the new user folder the same username and password as the old one?
     
  6. thumper thread starter macrumors 6502

    thumper

    Joined:
    Oct 25, 2003
    Location:
    Under the Sea
    #6
    i was installing Altered States.. it told me to reinstall it, i got some error... then went on safari
    to see if it was a bug or something and noticed that my safari prefs were all gone... so i restarted and now ive got a new defalt User with the same name and password
     
  7. fowler. macrumors 6502a

    fowler.

    Joined:
    Apr 18, 2004
    Location:
    Pasadena
    #7
    that's what she said
     
  8. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #8
    Alright, not enough information to know what's going on. Next time you have a problem, please entitle your thread something meaningful, and provide accurate, step by step account of what happened. I have no idea what Altered States is or why the installer would have moved you User folder. There's probably some other thing happened as well.


    I would create another new user, call it "RescueRanger" or something different from your regular username, with Admin priviledges, then boot from that.

    Once you are booted from the other user, you should be able to disable/move out the new, empty user folder that you accidentally created, then move your original user back into the Users folder.

    Maybe wait 'til someone else vets ths suggestion for any gotchas.
     
  9. thumper thread starter macrumors 6502

    thumper

    Joined:
    Oct 25, 2003
    Location:
    Under the Sea
    #9
    Heres what happend..

    -i was installing Altered state. (music soft synth) 4gigs
    -when i launched the app, i got an error.. saying please reinstall.
    -i then noticed i only had 300MB left on my Mac..

    -i opened safari to see if this error was a known bug with the program
    but when opening up safari i noticed all my prefs were gone.

    -i then restarted (thinking it would fix it) but instead ALL my prefs were gone. it was a bran new default User.. but with my same name and password.

    - I then noticed that my old user some how ended up in my App folder.

    So now i got 2 users with the same name and password on my Mac..
    the REAL one is in my App folder. and this new dummy one in the main user folder.

    when i tried to move my files back it told me i dont have access to do it.
    (even tho i am admin)
     
  10. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #10
    So do you still only have 300MB left? Have you managed to get at least 6GB free (more like 10GB if possible)?
     
  11. revenuee macrumors 68020

    revenuee

    Joined:
    Sep 13, 2003
    Location:
    A place where i am supreme emporer
    #11
    almost fell out of my chair
     
  12. thumper thread starter macrumors 6502

    thumper

    Joined:
    Oct 25, 2003
    Location:
    Under the Sea
    #12
    Thanks Canadian Ram for the help.

    --Heres how i fixed this mess--

    *so i found out the hard way that if your run out of
    disk space OSX starts deleting your Prefs to make more room.

    i was lucky and one of my apps got mad that its prefs were being deleted
    and moved my User Folder to the App folder for some odd reason.
    This saved all my stuff!

    I think its Protools/waves ilok that did this. (moved my User Folder)

    -on this new Cloned User i changed everything to Read & Write.
    -made a new admin user and deleted this cloned User and moved my
    Real User (in the app folder) back to the Main User Folder. along with
    the Shared Folder.

    repaired permissions and restarted

    BAM! IM BACK!!!

    I was always mad at this stupid ilok Key and the control it has over my
    Mac but this saved me!
     

Share This Page