Office 2004 Question

Discussion in 'Mac Apps and Mac App Store' started by reykjavik, Nov 9, 2005.

  1. reykjavik macrumors 6502

    Joined:
    Aug 31, 2004
    #1
    Anyone know ho wto speed up the process Word takes to "optimize the font menu"? It takes me a good 45 seconds to open Word solely because it is optimizing the font menu. Anyone know how to turn it off altogether or speed it up significantly?
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    It should only be doing that once, AFAIK. The first time you open one of the Office apps. You're seeing this everytime?
     
  3. reykjavik thread starter macrumors 6502

    Joined:
    Aug 31, 2004
    #3

    Yeah, every time I open Word, even if i haven't rebooted, it goes through this annoying process.
     
  4. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #4
    That's very unusual. I'd start by Quitting all Office apps, and removing a file:

    ~/Library/Preferences/Microsoft/Office Font Cache (11)

    Then start Word and it'll create the Font Cache anew. Then Quit Word and try opening it again. It shouldn't go through the caching phase again.

    Also, majke sure you'll all up to date on patches for Office 2004.
     
  5. reykjavik thread starter macrumors 6502

    Joined:
    Aug 31, 2004
    #5

    No, that didn't do it. Its decently quick when I open word, but when I open word from double clicking a word document, thats when it optimizes the font menu. I did what you said but its still doing it...
     
  6. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #6
    Well, let's be a bit more "shotgun" with our approach.

    Go ahead and quit Word (and any other Office app), then zip up the ~/Library/Preferences/Microsoft folder (select folder -> right-click -> Create Archive of "blah blah"), when it's done zipping, throw the Microsoft folder in the trash and empty it (don't worry you just zipped it to fall back on when/if this doesn't work). Now try running Word, it should be just like starting over. Once that's all over and done with, quit Word and open it again.

    There IS light at the end of the tunnel, I have Office 2004 and don't see what you're seeing.
     
  7. Bern macrumors 68000

    Bern

    Joined:
    Nov 10, 2004
    Location:
    Australia
    #7
    Just a thought, you're not running Onyx or Cocktail or anything similar by any chance?
     
  8. reykjavik thread starter macrumors 6502

    Joined:
    Aug 31, 2004
    #8
    Ok, so I don't know what Onyx or Cocktail is (although I did a spotlight search for both and Onyx the font showed up, is that what you were talking about?)

    I did what you recommended and it seemed to work, meaning it doesn't show that optomizing font at the bottom of the page anymore so thanks! However, it still takes a good 15 seconds to open, now I know that may come off as sounding greedy or whatever, but I mean, with a gig of ram and a G5 processor should it really take a full 15 seconds to open one basic word document? Also its not pirated software, I actually bought the software and have all the updates. On windows something like this would take 3-4 seconds max.

    Thoughts?
     
  9. wordmunger macrumors 603

    wordmunger

    Joined:
    Sep 3, 2003
    Location:
    North Carolina
    #9
    No, something is still wrong. It takes 3-4 seconds on my iBook and 2-3 seconds on my wife's powerbook to open MS word.

    Are you talking about a huge document or something just a few pages long?

    Edit: do you have a lot of fonts installed on your computer (more than, say 50)? That can slow a lot of things down.
     
  10. reykjavik thread starter macrumors 6502

    Joined:
    Aug 31, 2004
    #10

    NOt a huge document, 2 pages maybe 3. I opened fontbook and it says I have 904 Fonts. Should I disable them?
     
  11. Bern macrumors 68000

    Bern

    Joined:
    Nov 10, 2004
    Location:
    Australia
    #11
    Ok never mind. These are wysiwyg maintenance utilities which are sometimes used to empty certain caches.

    Don't mind me ....moving on now.
     
  12. swindmill macrumors 6502a

    swindmill

    Joined:
    Mar 17, 2005
    Location:
    KY
    #12
    I was having the same issue, although I didn't realize it was an issue until reading this thread. I trashed the preferences folder, and my start time has gone from about 15 seconds to about 2. The problem is I had custom toolbars in Word which took quite a bit of time to get right. Does anyone know which preference file holds this, so I can put that file in my new folder.

    EDIT: Found it. Thanks for tips. I'm glad I read this thread!!!
     
  13. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #13
    That's probably why you're having so much trouble. I have about 175 fonts.
     
  14. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
  15. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #15
    Yeah.. what he said. :)
     

Share This Page