Office v X

Discussion in 'Mac Apps and Mac App Store' started by indar20, Mar 5, 2003.

  1. indar20 macrumors newbie

    Joined:
    Jul 22, 2002
    #1
    I just installed Office v. X on my brand new 12" Powerbook. Ive noticed that Word runs very slowly though. It opens and saves documents quickly, but there is a definite lag when i delete content in a document or even when im just typing. I have 640 ram so I dont think its a hardware issue. I also have the latest Office Update. I wonder if there are specific preferences I can change (in office) that will improve the performance. Ideas?
    Suggestions?

    Thanks
     
  2. ibookin' macrumors 65816

    ibookin'

    Joined:
    Jul 7, 2002
    Location:
    Los Angeles, CA
    #2
    Re: Office v X

    Are you logged into the root account? I have noticed that that slows down Office considerably.

    Beyond that, try fsck and repairing permissions. It's kind of like a cure-all for OS X.
     
  3. SoonToGetAMac macrumors 6502

    Joined:
    Jan 27, 2003
    Location:
    California
    #3
    Yeah, I'm an a 700 iBook, and I have the same problem. I only have Word open, and I'm just typing and I suddenly get the beachball thingy. Its no big deal since I am usually looking at the keys, though. Not to hijack the post, but does anyone know how to remove an icon from the upper-right hand corner? (the AppleScript one in this case.)
     

    Attached Files:

  4. Flowbee macrumors 68030

    Flowbee

    Joined:
    Dec 27, 2002
    Location:
    Alameda, CA
    #4
    Command-click on the icon and drag it off the bar. Poof.
     
  5. indar20 thread starter macrumors newbie

    Joined:
    Jul 22, 2002
    #5
    Are you logged into the root account? I have noticed that that slows down Office considerably.

    Beyond that, try fsck and repairing permissions. It's kind of like a cure-all for OS X.


    thanks so much for the advice, but your gonna have to dumb it down a shade. what is a root account? what are fsck and repairing permisions? Thanks again .
     
  6. alex_ant macrumors 68020

    alex_ant

    Joined:
    Feb 5, 2002
    Location:
    All up in your bidness
    #6
    If you were logged in as root, you would know it, so you have nothing to worry about in that department, and also fixing permissions is unlikely to speed Word up at all. I think that's just the way Word is. If you open up Process Viewer you'll see that it eats up a fair amount of CPU even when it's not doing anything at all. I think Word is just inefficient like that. (Odd, because Excel v.X isn't that way at all for me.)
     
  7. Chad4Mac macrumors 6502

    Joined:
    Apr 20, 2002
    Location:
    Los Angeles
    #7
    Word is a snail on OS X. That's just the way it is.

    I wonder if Office v.X is optimized for the G4? I'm sure that they (Microsoft) could make Word and the rest of the suites run faster on a Mac. Is this a Microsoft, "your on a Mac so I'm going to F-you" thing, or am I off track?

    Chad4Mac
     
  8. scem0 macrumors 604

    scem0

    Joined:
    Jul 16, 2002
    Location:
    back in NYC!
    #8
    yeah, that isn't a hardware problem on the mac side. It is a
    program problem on the M$ side :rolleyes: . There isn't anything
    you can do about it (to my knowledge). MS will never make great
    software for the mac.... or so it seems. ;)
     
  9. mnkeybsness macrumors 68030

    mnkeybsness

    Joined:
    Jun 25, 2001
    Location:
    Moneyapolis, Minnesota
    #9
    make sure you have the newest updates from microsoft www.mactopia.com i noticed a vast improvement when i updated from the original
     
  10. hesdeadjim macrumors regular

    Joined:
    Jul 17, 2002
    Location:
    Austin, TX
    #10
    I have to agree here, it made Word bearable.
     
  11. aafuss1 macrumors 68000

    aafuss1

    Joined:
    May 5, 2002
    Location:
    Gold Coast, Australia
    #11
    Yes, try any recent updates to see if it soups up performance-just like service packs-could make your ccopy faster.
     
  12. ftaok macrumors 601

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #12
    In addition to making sure you have the latest updates, you should turn off "Active Word Count". Or something to that effect. Basically, if you have word count ON, it will eat up a lot of CPU. Turning it OFF will help out a little.
     

Share This Page