Old timer looking for help

Discussion in 'Mac Apps and Mac App Store' started by Kailish, Nov 1, 2005.

  1. Kailish macrumors newbie

    Nov 1, 2005
    Greetings All

    To start out with I have a old Beige G3 (233) and yes this is old.

    I am about to buy a New iMac, my questions are.

    Will Quark 4.1 run on the new OS
    Will Photoshop 5.5 run on the new OS
    Will Illustrator 8 run on the new OS

    What programs will I need to help?
    Font manager??
    Any other suggestions??
  2. Jaffa Cake macrumors Core

    Jaffa Cake

    Aug 1, 2004
    The City of Culture, Englandshire
    Quark 4.1 will run under Classic (that's how we use it at work) – it has a few quirks but you should be able to run it fine. We ran Illustrator 8 and Photoshop 5.5 in Classic on an earlier version of OS X and they worked fine – I would imagine they'd do the same under Tiger but don't quote me on that.

    You'll need Adobe Type Manager installed to make the Classic apps render your type nice and smooth, in Quark certainly.
  3. yenko macrumors 6502a

    Aug 29, 2005
    It's time to do a serious upgrade. Forget that old stuff. You're not saving anything by trying to make old software work on a new OS.
    The new stuff is so much better. Spend the money and get the current software to match the operating system, you won't regret it.
    I was reluctant to make the switch at first. It took me a couple of weeks to adjust to OS X; haven't looked back since. ;)
  4. ~Shard~ macrumors P6


    Jun 4, 2003
    Jaffa Cake is correct, your apps will run in Classic with little difficulty, however I, too, recommend treating yourself to the current versions of these apps. I don't know your financial situation, and I know it's tough to shell out a lot of cash for new software, but compared to the versions you're currently using, the new versions are significantly improved and I think it would be worth it for you. Then you can also take full advantage of running nice new software on your nice new machine without having to do any "Classic vooodoo". ;)

    Personally I thin it is worth the investment, but I understand the bank account sometimes won't allow it... ;)

Share This Page