OmniFocus not Working in Mountain Lion

Discussion in 'OS X Mountain Lion (10.8)' started by HappyDude20, Feb 28, 2012.

  1. macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #1
    Hi guys,

    I'm an enthusiastic OmniFocus user and since downloading Mountain Lion many OF users have not been able to open their beloved OF app within ML. The OmniFocus forums are being a bit vague about posting a workaround (as one does exist) considering it seems to violate Apple's NDA; but in all honesty am not too sure on the details.

    I'm posting here on the off-chance that another OmniFocus/Mountain Lion user is seeking the same solution as I am; trying to get OF to work in ML.

    Any advice is truly appreciated.
     
  2. macrumors newbie

    Joined:
    Feb 28, 2012
    #2
    Omnifocus not working on Mountain Lion

    Hey

    I'm also having the same problem. Really need the fix, this will help me alot.
     
  3. macrumors newbie

    Joined:
    Aug 16, 2009
    #3
    Same issue here

    Omnifocus doesn't run on Mountain Lion.

    It just crashes at the beginning with a dialog that says "Saving state" :(
     
  4. thread starter macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #4
    !!!!!!!!!!!!!!!!!!!!!

    come on OmniFocus!
     
  5. macrumors 603

    Joined:
    Aug 29, 2008
    Location:
    UK
    #5
    Mountain Lion is a Developer Preview or beta software. Therefore it should. It be used for production environments as many things are not working or working as expected. You should not expect software vendors to develop or fix bugs at this very early stage but to look at implementing features. Support, of course could be limited.
     
  6. Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    Really? You're chastising OmniGroup for not updating their application to make it compatible to an unreleased OS?

    The purpose of a developer preview is to do just that, so don't you think they're using 10.8 for that purpose and when 10.8 is released OmniGroup will release an update
     
  7. macrumors 6502a

    Joined:
    Jun 2, 2008
    #7
    The workaround has been posted at https://devforums.apple.com/message/621717. You do need to be a registered Mac developer to get access to that forum. Since you have to be one for the Mountain Lion preview, accessing it should not be a problem.

    Also, this is actually an OS X bug, not an Omnifocus bug. The workaround changes how framework functions work.
     
  8. macrumors 6502

    Joined:
    Mar 14, 2011
    #8
    Agreed. It's pretty disappointing how indignant people seem to get when they steal a developer preview, install it as their primary OS, and then their beloved apps no longer work. If this is the first developer preview release then when exactly were the app developers supposed to update their program to run? That literally is the entire purpose of a developer preview in the first place so that their apps are up to speed by the time the OS makes its public release.
     
  9. macrumors 604

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #9
    Way too many people think it's perfectly OK to steal unreleased software then complain how something doesn't work.
     
  10. macrumors member

    rodpascoe

    Joined:
    Jun 19, 2006
    Location:
    Newquay, Cornwall
    #10
    This guy could be a genuine apple tester. It's not expensive to buy an Apple Developer Subscription.

    Perhaps cut him a little slack until you know otherwise?
     
  11. macrumors 604

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #11
    I did not state that the OP was or was not a genuine tester. I only commented on blipps post.
     
  12. macrumors 6502

    Joined:
    Mar 14, 2011
    #12
    If he were a "genuine tester" he'd be submitting bug reports to Apple and the app developers instead of complaining on a web forum...

    Either way if you choose to install beta software, licensed or not, as your primary OS then you're asking for the kinds of trouble he's running into.
     
  13. macrumors member

    Joined:
    Mar 10, 2012
    Location:
    Rhode Island
    #13
    Wait for public release of ML this sumner and post again if it's still a problem.
     
  14. Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #14
    Not necessarily the two are not mutually exclusive. They can submit a BR, add a thread to the ML support forums at apple and still post here.

    Of course by doing that thy violate the NDA they agreed too
     
  15. macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #15
    If the OP were a developer they should know better than complain about third party software not running on a developer beta.
     
  16. thread starter macrumors 68020

    HappyDude20

    Joined:
    Jul 13, 2008
    Location:
    Los Angeles, Ca
    #16
    I didn't mean to chastise OmniFocus one bit. Admittedly, this
    Was
    My
    First developer download since signing up for the app debeloeper program. Needless to say I was frustrated and here we are. I solved the problem via the appleseed support site.

    I did start this thread in regards
    To
    Having been a member forgone years
    Years now and it being the best/most
    Site
    I
    Visit.

    Apologies of this stirred
    Up
    Some
    Replies.

    I am loving mountain lion though. I'm heavily considering selling my Mbp if a
    Brand we revamped Mbp comes out this summer.
     

Share This Page