ongoing Safari issue

Discussion in 'Mac Apps and Mac App Store' started by MacsomJRR, May 24, 2005.

  1. MacsomJRR macrumors 6502a

    MacsomJRR

    Joined:
    Jul 8, 2003
    Location:
    San Diego
    #1
    Ok, so I've had this ongoing problem with Safari that I've been trying to figure out for awhile now and I'm at my wits end.

    Here's the problem.

    The majority of the time, whenever I click on any kind of a button to try to download a link Safari will just kinda hang for about two seconds, then try to download the file (usually accompanied by a little loading bar in the bottom right). Instead of then downloading the attached file Safari will briefly open up a blank page (in same window) and then promptly shoot me back to the original page where I had clicked the link. The file never downloads:(

    This problem occurs on any page in which there is a "button" as the link for the download instead of the usual blue colored link.

    Some example pages are www.handango.com, www.palmgear.com and any sites (can't think of any right now:)) that use this download style.

    As you can probably tell I'm not a computer programmer so I may not be describing the issue very well. Sorry:(

    Can anyone tell if I am doing something wrong??? Have a mistakenly turned on some strange hidden feature that simply needs to be turned off??? I have tried just about everything in the regular Safari and System prefs and am still having problems.

    Thanks for any help you can offer. This will be much appreciated!!!!
     
  2. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
  3. MacsomJRR thread starter macrumors 6502a

    MacsomJRR

    Joined:
    Jul 8, 2003
    Location:
    San Diego
    #3
    Yes I have tried right clicking and option clicking etc... to no avail:(
     

Share This Page