open office not working

Discussion in 'MacBook Pro' started by bored911, Feb 23, 2007.

  1. bored911 macrumors 6502

    bored911

    Joined:
    Feb 18, 2007
    Location:
    NYC
    #1
    My open office.org is not working. when i try to open it, it says you must have x11 installed. i tried to install it, but it wouldn't work. any suggestions, thanks!
     
  2. dpaanlka macrumors 601

    dpaanlka

    Joined:
    Nov 16, 2004
    Location:
    Illinois
    #2
    You want NeoOffice, the Mac version of OpenOffice for starters.
     
  3. bored911 thread starter macrumors 6502

    bored911

    Joined:
    Feb 18, 2007
    Location:
    NYC
    #3
    thanks

    thank you, i was just wondering why open office says you need x11. but neo office is great
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    Because you do need X11 to run OOo.

    The backstory is that the main OOo stream's heaviest users are Windows users plus Linux users (who get preference since many of the developers are probably also Linux people). The main branch didn't want to develop an Apple-native interface. Apple implemented X11, which is the basis of windowed interfaces in Unix and Linux, in OS X as well. So it was much easier for the OOo team to develop for X11 than it would have been to develop for Aqua, and so they did. Same deal with GIMP.

    NeoOffice is a branch of OOo that was developed off of existing OOo builds and adapted to have a native OS X interface. :)

    So really it's the one you want anyway.... OOo is probably faster, but it won't look as nice or play as well with other apps.
     

Share This Page