Opening .NZB files into SABnzbdX makes Mac OS X think it's a program?

Discussion in 'Mac Applications and Mac App Store' started by Doju, Nov 6, 2009.

  1. macrumors 68000

    Joined:
    Jun 16, 2008
    #1
    It isn't, so there's really not a massive problem with this, but I'm annoyed that every time I want to open these .NZB files (which, btw, are like the equivalent of .torrent files for those of us who use Usenet) it treats it like an app with all the "You are opening Ubuntu 9.10.nzb for the first time and this was downloaded from the internet at yada yada." and it's a bit of an annoyance.

    Is there like a terminal command I can use to make it stop? I don't really think opening up .NZB files are a security threat worthy of this notification, is it?
     
  2. Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #2
    I've noticed this with Unison since 10.5.8, does it in 10.6 too. Not really sure what Apple changed, but it is annoying.
     
  3. macrumors regular

    OddyOh

    Joined:
    Nov 29, 2005
    Location:
    Regina, SK, Canada
    #3
    yup

    Yeah I had that problem, and it was super-annoying because I use iCal to run an Automator script to download my files to download them overnight...but I would check my mac in the morning and sure enough, just sitting there with the stupid 'this file is from the Internet' warning...well, freakin' DUH!! :)

    Anyway, I did solve it...I found a blog post that showed how to edit a certain 'plist' file so it just plain opens certain file types. It's customizable, so I added a line for NZB types, and now it's smooth sailin' again.

    I'm at work right now, but I can check back when I get home and tell you what plist it was. Hope that helps. I don't remember what phrase I google'd.
     
  4. thread starter macrumors 68000

    Joined:
    Jun 16, 2008
    #4
    That'd be great, thanks a lot. Glad I'm not alone.
     
  5. macrumors regular

    OddyOh

    Joined:
    Nov 29, 2005
    Location:
    Regina, SK, Canada
    #5
    cool

    Ok, cool I found it.

    It should be in "Users/yourusername/Library/Preferences/" and it's called "com.apple.DownloadAssessment.plist", open it in textedit or whatever.

    Here's what mine looks like:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    	<key>LSRiskCategorySafe</key>
    	<dict>
    		<key>LSRiskCategoryContentTypes</key>
    		<array>
    			<string>public.html</string>
    			<string>public.xml</string>
    			<string>public.php-script</string>
    			<string>com.microsoft.windows-media-wmv</string>
    		</array>
    		<key>LSRiskCategoryExtensions</key>
    		<array>
    			<string>xhtml</string>
    			<string>nzb</string>
    		</array>
    	</dict>
    </dict>
    </plist>

    I think I basically just added the "<string>nzb</string>" line near the end.

    Try that out, but maybe make a copy of the original...I don't want to hose your system!!! :)
     
  6. thread starter macrumors 68000

    Joined:
    Jun 16, 2008
    #6
    Hmm, I don't have that download.plist file. :(
     
  7. macrumors newbie

    Joined:
    Nov 7, 2009
    #7
    Just go ahead and create it. :)

    Be warned, if you have used Amazon downloads, Amazon likely has created this file and given it an encoding of "UTF-8, no BOM". This doesn't work, and just editing it won't change the encoding. Open it in TextWrangler or BBEdit, do a Save As and use the Options button and subsequent dialog to set the file encoding to UTF-8 (with "no BOM" on the end), and save over the old file. This is why the technique is working for some people (those who create it from scratch) and failing for others (those who have the Amazon-created file with bad file encoding), I think.

    A longer-winded explanation and some other things I tried before getting it to work (but am pretty sure are unnecessary) may be found here.
     
  8. macrumors regular

    OddyOh

    Joined:
    Nov 29, 2005
    Location:
    Regina, SK, Canada
    #8
    create

    Yeah, I must have created my own file, I don't use any Amazon download stuff...we don't have that in Canada. But I can't find the original instructions I used, I thought I'd bookmarked it.
     
  9. macrumors 6502

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #9
  10. macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    上海 (Shanghai)
    #10
    I guess this workaround is nice. I've gotten so used to this, that I've learned to accept. It's kind of having turned into Windows Vista's UAC except harder to turn off.
     
  11. macrumors regular

    OddyOh

    Joined:
    Nov 29, 2005
    Location:
    Regina, SK, Canada
    #11

Share This Page