OS 10.1.5 wont run anything!

Discussion in 'Mac Apps and Mac App Store' started by OB142, Feb 19, 2004.

  1. OB142 macrumors newbie

    Jan 29, 2004
    I'm not really hoping for much, but here goes....

    I've got an iMac running OS 10.1.5 and have been frustrated recently when I've tried to get applications to run.

    For example I downloaded the UT2004 demo this evening, hoping for a game with my friends. When unpacked however the icon was the white sheet of paper with the corner folded over. This has happened with other things I've tried to install recently (not just games).

    This is what I think is going on: it seems that OS 10.1.5 is just too old to run any new stuff (seems to be 10.2 or later). I dont really understand this as on a windows system a new program would run on 98, 2000, NT, XP etc.

    Is this true that if you dont have the latest OS, new software wont run???

    If so is there any way of updating for free. (I'm not being cheap, I just think it isn't really fair to have to buy every new .1 of OSX just so new software will actually work) :confused:

    Can someone please suggest something :) or tell me its hopeless and I just have to buy the newest OS. :(
  2. janey macrumors 603


    Dec 20, 2002
    sunny los angeles
    this is just like the safari 1.2 update argument.

    the fact is that the games (regardless of whether or not they are demos) take advantage of new technology in newer OSs that arent in older ones.

    The ut2k4 demo needs a minimum of at least OS X version 10.2.8 iirc (correct me if i'm wrong)

    you cant get OS upgrades for free. but you can get them for relatively cheap.
  3. jxyama macrumors 68040


    Apr 3, 2003
    Re: OS 10.1.5 wont run anything!

    check the min. requirements for the programs you want to run and get at least a jaguar, if not panther.

    no other way around it... sorry, bud. :(
  4. Dont Hurt Me macrumors 603

    Dont Hurt Me

    Dec 21, 2002
    Yahooville S.C.
    Hate to mention this but if your Imac is running 10.1.5 that means you dont have the cpu,videocard and the Os to run UT2003 or 2004. Just forget this idea 100%. Even brand new imacs with g4 1.25 and os 10.3 UT2004 isnt going to run well on. welcome to Macs hardware 101.:(
  5. laserbeahm macrumors member

    Feb 4, 2004
    Central Valley, CA
    Mac OSs get outdated very quickly. I had the same problem when I had a Quicksilver running 10.0... it couldn't run SimCity 4.
  6. MoparShaha macrumors 68000


    May 15, 2003
    San Francisco
    10.0 was a disaster. Apple had to change the kernal for 10.1, so nothing will run on 10.0.
  7. latergator116 macrumors 68000


    Sep 30, 2003
    Providence, RI
    10.0 was equivelant to a really crappy beta. It came with my iBook, but I always ran OS 9 until 10.2 came out.

Share This Page