OS 10.2 Appletalk printer problem

Discussion in 'macOS' started by pepeleuepe, Jul 13, 2005.

  1. pepeleuepe macrumors 6502

    Oct 27, 2002
    Los Angeles, California
    After a power outage my Appletalk printer isn't communicating with OS 10.2.8 anymore. When I go to the Print Center, all that it says is "Unable to connect to any Appletalk printers, Appletalk is not turned on" but when I check in the Network Preferences, the "Make Appletalk Active" tab is checked.

    I've tried repairing permissions and restarting the computer a couple times. I've also tried to turn Appletalk on and off a couple times. Not sure what to do next. Let me know if anyone has any ideas.

  2. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    You might want to stick in the CD/DVD and run Disk Utility, and Repair Disk.

    If the machine shut crashed during the storm, there may be some file system/catalog problems.

    If it does find problems, keep running it until they are all repaired (or worse it stops repairing the problems.)

    Once those are taken care of, run repair permissions off the Hard Drive -- not off the CD/DVD.
  3. pepeleuepe thread starter macrumors 6502

    Oct 27, 2002
    Los Angeles, California
    So, after some intense reading up on Appletalk I managed to solve some problems with the help of Google and another person on a forum that had a similar problem here.

    I made an Applescript that performed the fix mentioned at the link above each time the computer started up. This worked fine but was more of a workaround than a solution.

    Turns out one of the Mac OS X guru's from a downstairs office came and found a config file buried in the settings of the system that had been corrupted. After I told him what the problem was, he was able to fix it very quickly. Wish I had remembered where the file was (I think it was in /etc somewhere) so that I could share the fix, but the above link has a workaround that, with some Applescripting, solves the problem as well.

    Thanks for the suggestions, problem solved.

Share This Page