OS X bug - Finder forgets the selected item arrangement

Discussion in 'OS X Mountain Lion (10.8)' started by jvpython, Oct 10, 2012.

  1. macrumors 6502

    Joined:
    Aug 25, 2011
    Location:
    New Zealand
    #1
    This is a very annoying bug I've been having since Mac OS X Lion and Apple still hasn't fixed it. I've sent them a bug report but I haven't heard anything back. Has anyone else been having this issue. I've included steps to reproduce it hopefully:

    For most of my folders I have set the "Arrange By" to name. Also I adjusted the size of the icons and the spacing between them. But every time I am in an app and I use the Open File window and navigate to a folder I have arranged, it will be all mixed up and all my size adjustments etc. will be forgotten when I go back to that folder in the Finder. It is quite frustrating as I have to rearrange the items every time. I am using a mid 2012 15" MacBook Pro and the issue has been present from the first version of Mountain Lion and is still here as of 10.8.2 . I also had this same issue with my late 2008 MacBook Aluminium.

    Steps to Reproduce:
    1) Go to a folder in the Finder which contains several files / subfolders and select "Arrange By" and "Name". Do any other adjustments to the icon sizes and spacing.
    2) Go to an app such as Text Edit and go to "File" then "Open...". Navigate to the folder from the previous step then close the Open File window.
    3) When you go back to that Folder in the Finder all your arrangements will be forgotten and the folders / files there will all over the place.
     
  2. thread starter macrumors 6502

    Joined:
    Aug 25, 2011
    Location:
    New Zealand
    #2
    Forgot to mention. I'm using TotalFinder. But I don't believe that it is what's causing the issue.
     
  3. macrumors 6502a

    dcorban

    Joined:
    Oct 29, 2007
    #3
    I followed your instructions and could not reproduce.

    I went to my Documents folder, set it to icon view, sorted by name, and moved some stuff around. Closed the window. Opened Textedit, File->Open, navigated to Documents folder. The view there looked different from my Finder arrangement, but that's fine. Closed Textedit. Opened Finder window, went to Documents, and everything looked exactly as I had arranged it earlier.

    ----------

    I tried it again, and this time made even more drastic changes. I made the icons and spacing as small as possible. I changed other things like text size and icon preview. In Textedit, I tinkered with the sorting there as well. Finder still shows my custom layout when I reopen the folder.

    I think it may be your "Totalfinder" thing after all, whatever that is.
     
  4. thread starter macrumors 6502

    Joined:
    Aug 25, 2011
    Location:
    New Zealand
    #4
    http://totalfinder.binaryage.com/
    Here is TotalFinder. I'll uninstall it and see if it makes a difference
     
  5. thread starter macrumors 6502

    Joined:
    Aug 25, 2011
    Location:
    New Zealand
    #5
    Ok so I uninstalled it, and at first the problem seemed to be gone. I tried opening files and it had no effect then a little while later I opened something from Stuffit Expander and the issue happened again... I guess the bug didn't come from TotalFinder after all...
     
  6. tug
    macrumors 6502

    Joined:
    Feb 3, 2010
    Location:
    loughborough. u.k.
    #6
    same happens here its got to be a problem within M/L.
     
  7. macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #7
    .DS_store is a hidden file in each folder that contains info on finder folder/file arrangement, view, labels, etc.
    Sounds like somewhere along the way one of your 3rd party apps may have modified the applicable preference list..

    If you're comfortable editing plists check out com.apple.desktopservices.plist for anything that might cause this.

    I know it isn't a definitive solution, but hopefully I have given you something to go on.
     
  8. thread starter macrumors 6502

    Joined:
    Aug 25, 2011
    Location:
    New Zealand
    #8
    How strange... In ~/Library/Preferences I can find a file named com.apple.desktop.plist but not com.apple.desktopservices.plist
     
  9. macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #9
    It's there on my 10.8.2 install, but it's kind of bare..

    I wonder if it would change anything if you just copied it over, as I do not see anything in the file that was customized by my user preferences.

    Download it here if you want to give that a shot.

    [​IMG]
     
  10. macrumors member

    Joined:
    Sep 13, 2010
    #10
    This would happen to me as well (2010 MBP 13" / 10.8.2.) with no mods in finder so you aren't the only one. I though that if I went into "Disk utility" & verified & repaired disk permissions it would help to some degree. I really think this cleared up the issue as I've haven't encountered it again so far. If this holds true, it advisable to repair disk permissions after every update.
     
  11. thread starter macrumors 6502

    Joined:
    Aug 25, 2011
    Location:
    New Zealand
    #11
    Tried adding the plist file to ~/Library/Preferences but the issue remained. Then I repaired the disk permissions (I noticed it was repairing a permission with DS_Store file) but that still didn't change anything... Thanks anyway :)
     

Share This Page