1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

OS X Lion DP4 on 2011 MacBook Pro 13"

Discussion in 'Mac OS X Lion (10.7)' started by SmoothxCaller, Jun 9, 2011.

  1. macrumors newbie

    I have been trying for 2 days to get Lion installed, but it just won't work.
    Every time I reboot to start the installing process, my mac freezes.
    Have tried every method on this forum (start process in single user mode, repair disk, ...).

    Has anybody been able to get it installed on a new 13" MBP?
  2. macrumors newbie

    Anyone ?
  3. macrumors 6502a


    Are you installing it to a second partition?
  4. macrumors newbie

    Yes, a fresh partition made in snow leopard.
  5. macrumors 6502a


    What do you mean by freezes? When does it freeze ? Keep in mind the installation DVDs take a long time to boot to most of the time.
  6. macrumors newbie

    Well, most of the time the spinner underneath the apple logo just stops, and stays that way.
    When I launch the installer using single user mode I usually reach the install process but when it says 'installing', it just freezes again.

    Main problem: I can't get the Lion install process launched/completed after installing the setup files using Snow Leopard.

    I also tried with a bootable DVD and USB, but my mac fails to launch those.
  7. macrumors 6502a


    So is your image from the app store or third party?
    Could it be a problem with the image?

    I have read problems with the new mbp and lion though. Is it the new developer preview? Also elaborate on installed the setup files using snow leopard are you referring to running the install through sl?
  8. macrumors newbie

    I have tried 3 different image files, all files that worked with other users.
    So problem can't be with the image file.

    It is indeed the latest developer preview.

    And indeed i refer to running the install through SL.
  9. macrumors member

    i cant install Lion either , in my new mbp 2011 15.4
    Its not "compatible" ... its the wifi driver that fails.

    We have to wait until the final version...
  10. macrumors 6502

    Seriously, if it's this much trouble, wait till the final version. I've installed about 5 times now; I'm going to be reverting to 10.6.7 shortly. Yes, the new features are nice, but nothing is "nice" enough to tolerate the amount of bugs I've been dealing with.

    After several different fresh installs, the only way I can get sound enabled EVERY TIME I REBOOT is by plugging in a separate USB card (an item most people do not even own). After several installs, keys will not repeat on the keyboard. Just suddenly stopped working about 30 minutes ago. Nothing brings it back; not a different keyboard, not a restart. Nada.

    Just wait. Seriously, just wait if it won't even install. Do something better with this time. I promise the features will still be there when they've actually come up with a stable release, and they are not worth this much time and energy wasted.
  11. macrumors newbie

    I'm having exactly the same problem. On a mbp 13" 2011 too. After reboot installer just hangs on the boot logo. Sometimes it shows some kind of an graphics glitch just before freezing. In verbose mode it hangs right after "DSMOS has arrived".

    I'm installing to an USB drive btw, upgrade from dp3.
  12. macrumors newbie

    That's exactly whats happening on my macbook.
    But you were able to install DP3?
    How did you do that?
  13. macrumors newbie

    I'm not sure, could be DP2 too actually. I've installed a version a few months ago, then upgraded through software update (was that dp2?).
  14. macrumors member


    I'm using DP4 on a 13" MacBook Air.

    Here's how I installed:

    - Did a Carbon Copy Clone of my drive to an external USB drive.
    - First time just upgraded my Snow Leopard installation. It gave an error half way through and said couldn't upgrade.
    - Installed a clean system using the original USB system stick.
    - Upgraded to 10.6.6
    - Did the Lion upgrade and it worked fine.
    - Used the migration assistant to load all my apps and files from my external USB drive.

    Here are the issues I'm having:

    - A few apps needed to be upgraded to nightly builds eg. Transmission
    - Parallels is not quite right, but using a workaround made it boot into windows 7 OK. No internet in it though.
    - Going to sleep once logged in causes the computer to freeze when waking. Sleeping while at the login screen works fine. I think it's something I'm running that's not working, but having trouble working out what it is. I have heaps of stuff installed.
    - I would suggest starting with a fresh install, and adding each thing in one at a time.
  15. aldejesus, Jun 9, 2011
    Last edited: Jun 10, 2011

    macrumors regular

    Yes. Did a fresh OS Install (DVD) restore via time machine backup. Then installed the DP4.
  16. macrumors newbie

    I installed Lion DP4 a couple of days ago on a freshly created second partition on my 2011 MBP 15'' with absolutely no problems...
  17. macrumors newbie

    In order to have new MBP 2011 working with DP4 use build 11A480e, then it works like a charm.
  18. macrumors member

    The latest DP4 build from the Mac App Store fixes the issues with the 2011 MPs as I was a sufferer. If you downloaded from 3rd party, make sure it's the latest build of DP4 and not the previous build.
  19. macrumors 6502


    11A494a is working fine on my 13" '11 MBP i5. Runs great. Installed it to a newly created partition on my SSD. Sl on the main partition and Lion on the new one. Been using Lion exclusively for a couple weeks now and have found little to no issues with my daily use. Can't wait for the release.

Share This Page