OS X ML, Xcode 4.4.1 and Macports

Discussion in 'OS X Mountain Lion (10.8)' started by meme1255, Sep 13, 2012.

  1. macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #1
    Hi,
    I'm have a problem with Macports since ML ( of course I had updated Macports and done everything what was written in FAQ ): I'm recieve this error for nearly any app :( :

    Specifications:
    OS X ML, Xcode 4.4.1 and Macports , ML updated from Lion..

    I've read somewhere that Xcode 4.4 is not supported - How could I use XCode 3 which I have too? :)

    Thanks,
    meme
     
  2. Intell, Sep 13, 2012
    Last edited: Sep 13, 2012

    macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    You can't use Xcode 3 in OS X 10.8. I suggest using homebrew instead and installed the Xcode command line toolkit downloadable from Apple's developer site.
     
  3. thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #3
    Xcode command line tools I installed with Xcode ;) .. I'll try
     
  4. macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    I mistyped that. The thing is called homebrew. It's a command port package like MacPorts or Fink. Only it's cleaner and better.
     
  5. meme1255, Sep 13, 2012
    Last edited: Sep 13, 2012

    thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #5
    Google fixed that for you ;) - downloading already :)
    Thanks

    ----------

    I would need X11 vlc - is it somehow possible to install it with brew? :(

    --------

    I'll try this http://coderwall.com/p/pagj2w
     
  6. thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #6
    sudo port install -vu apple-gcc42
    Password:
    ---> Computing dependencies for apple-gcc42
    ---> Dependencies to be installed: cctools ld64 libunwind-headers llvm-3.1 llvm_select gcc_select
    ---> Building libunwind-headers
    Error: org.macports.build for port libunwind-headers returned: command execution failed
    Error: Failed to install libunwind-headers
    Please see the log file for port libunwind-headers for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_libunwind-headers/libunwind-headers/main.log
    Error: The following dependencies were not installed: cctools ld64 libunwind-headers llvm-3.1 llvm_select gcc_select
    To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
    Error: Processing of port apple-gcc42 failed


    :/
     
  7. dyn, Sep 13, 2012
    Last edited: Sep 13, 2012

    dyn
    macrumors 68000

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #7
    OS X Mountain Lion, Xcode 4.4.1 and MacPorts 2.1.2 work fine together. You may want to upgrade your MacPorts by typing "port selfupdate". This also updates your MacPorts collection. Version 2.1.2 is compatible with Mountain Lion. In Xcode you also need to install the command line tools manually. You do that by going to the Xcode preferences > Downloads. Select the cli tools and hit the install button.

    The use of homebrew is definitely NOT to be recommended. That system is setup very insecurely. You must change the defaults which will cripple Homebrew (do NOT let it install into /usr/local because it will screw up the permissions which will wreak havoc if you have certain tools installed!). Currently MacPorts is the best way to go mainly because it leaves /usr/local alone. Also the fact that the homebrew developer ignores all the security and install issues (he says there is no problem changing the permissions of /usr/local which is BS) is not speaking in homebrews favour. Too bad because it is quite a nice system.
     
  8. thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #8
    :eek: I've done already everything from thing that you suggest me :rolleyes:
     
  9. macrumors 6502

    Joined:
    Dec 26, 2009
    #9
    I upgraded from Snow Leopard and took Xcode 3 with me and it's working perfectly fine.
     
  10. dyn
    macrumors 68000

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #10
    Have you checked the log files, like this one: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/main.log? What do the logs say?
     
  11. thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #11
    nfo:build make[5]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/work/vlc-0.9.10/modules/access'
    :info:build make[4]: *** [all-recursive] Error 1
    :info:build make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/work/vlc-0.9.10/modules/access'
    :info:build make[3]: *** [all] Error 2
    :info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/work/vlc-0.9.10/modules/access'
    :info:build make[2]: *** [all-recursive] Error 1
    :info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/work/vlc-0.9.10/modules'
    :info:build make[1]: *** [all-recursive] Error 1
    :info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/work/vlc-0.9.10'
    :info:build make: *** [all] Error 2
    :info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/work/vlc-0.9.10'
    :info:build Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/work/vlc-0.9.10" && /usr/bin/make -j2 -w all
    :info:build Exit code: 2
    :error:build org.macports.build for port VLC09 returned: command execution failed
    :debug:build Error code: CHILDSTATUS 49722 2
    :debug:build Backtrace: command execution failed
    while executing
    "system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
    "eval system $notty $nice \$fullcmdstring"
    invoked from within
    "command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
    "$procedure $targetname"
    :info:build Warning: targets not executed for VLC09: org.macports.activate org.macports.build org.macports.destroot org.macports.install
    :notice:build Please see the log file for port VLC09 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC09/VLC09/main.log
     
  12. dyn
    macrumors 68000

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #12
    I wasn't paying a lot of attention...I looked for the "VLC09" port and it is more ancient than Julius Caesar :D The port named "VLC" is an up to date version (2.0.2 at time of writing). You can build this version with x11 support by typing sudo port install vlc +x11 to install it.
     
  13. thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #13
    ake[6]: *** [libqt4_plugin.la] Error 1
    make[6]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4/modules/gui/qt4'
    make[5]: *** [all] Error 2
    make[5]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4/modules/gui/qt4'
    make[4]: *** [all-recursive] Error 1
    make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4/modules/gui'
    make[3]: *** [all] Error 2
    make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4/modules/gui'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4/modules'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4'
    make: *** [all] Error 2
    make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4'
    Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4" && /usr/bin/make -j2 -w all DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/work/VLC-2.0.4/dest_ignore
    Exit code: 2
    Error: org.macports.build for port VLC returned: command execution failed
    Warning: targets not executed for VLC: org.macports.activate org.macports.build org.macports.destroot org.macports.install
    Please see the log file for port VLC for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_VLC/VLC/main.log
    To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
    Error: Processing of port VLC failed

    I've tried to install VLC09 because VLC wouldn't even start building
     
  14. thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #14
    VLC installed ( I tried it maybe twelve times) :eek:

    But it doesn't work - [0x1003076a0] main libvlc error: No plugins found! Check your VLC installation.
     
  15. macrumors Pentium

    KnightWRX

    Joined:
    Jan 28, 2009
    Location:
    Quebec, Canada
    #15
    Why are you trying to build VLC from macports anyhow ? Just install their binary off their site.

    And btw, you keep cutting out the real error message from the logs you post (use the CODE tag btw for those logs).
     
  16. meme1255, Sep 15, 2012
    Last edited: Sep 15, 2012

    thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #16
    I want it because it supports X11 forwarding, which I would like to use on iMac with Lion & 3GB RAM (There are Win XP in bootcamp and problem with update to Moutain Lion, I would have to delete Win XP and I don't want to) ( I have 8GB) - I would save a bit of memory on iMac by X11 forwarding of VLC & Firefox (Which has problems with compiling too, :(, I am trying to compile it as x86 instead x86_64 app)

    Log from VLC-dev (I've had cleaned VLC and installing FF at the moment) -
    View attachment main.txt
     
  17. macrumors Pentium

    KnightWRX

    Joined:
    Jan 28, 2009
    Location:
    Quebec, Canada
    #17
    You do realise X11 forwarding is going to be dog slow for movie watching right ? For firefox it might be bearable, but I doubt it would be for VLC. And with 3 GB of RAM, you won't have a problem running both Firefox and VLC at the same time, so really you shouldn't bother.

    Now, for your problem, this is the error message you're getting :

    Code:
    :info:build libtool: link: /usr/bin/llvm-gcc-4.2 -std=gnu99 -mmacosx-version-min=10.8  -o .libs/libaccess_fake_plugin.dylib -bundle  .libs/libaccess_fake_plugin_la-fake.o   -L/opt/local/lib ../../src/.libs/libvlccore.dylib -lpthread -lm /opt/local/lib/libintl.dylib /opt/local/lib/libiconv.dylib -lc  -mmacosx-version-min=10.8 -O3 -O2 -arch x86_64 -arch x86_64 -Wl,-headerpad_max_install_names  
    :info:build libtool: link: ( cd ".libs" && rm -f "libaccess_fake_plugin.la" && ln -s "../libaccess_fake_plugin.la" "libaccess_fake_plugin.la" )
    :info:build qtcapture.m: In function 'qtchroma_to_fourcc':
    :info:build qtcapture.m:173: error: 'k422YpCbCr8CodecType' undeclared (first use in this function)
    :info:build qtcapture.m:173: error: (Each undeclared identifier is reported only once
    :info:build qtcapture.m:173: error: for each function it appears in.)
    :info:build qtcapture.m:174: error: 'kComponentVideoCodecType' undeclared (first use in this function)
    :info:build qtcapture.m:175: error: 'kComponentVideoUnsigned' undeclared (first use in this function)
    
    Looking at the current code, it seems that the qtchroma_to_fourcc method does not use those types anymore though :

    http://www.videolan.org/developers/vlc/modules/access/qtcapture.m
    Code:
    /*****************************************************************************
    * qtchroma_to_fourcc
    *****************************************************************************/
    static int qtchroma_to_fourcc( int i_qt )
    {
        static const struct
        {
            unsigned int i_qt;
            int i_fourcc;
        } qtchroma_to_fourcc[] =
        {
            /* Raw data types */
            { '2vuy',    VLC_CODEC_UYVY },
            { 'yuv2',VLC_CODEC_YUYV },
            { 'yuvs', VLC_CODEC_YUYV },
            { 0, 0 }
        };
        int i;
        for( i = 0; qtchroma_to_fourcc[i].i_qt; i++ )
        {
            if( qtchroma_to_fourcc[i].i_qt == i_qt )
                return qtchroma_to_fourcc[i].i_fourcc;
        }
        return 0;
    }
    Seems you're trying to build an outdated version of the source. run the following commands and try to rebuild VLC :

    Code:
    $ sudo port clean --all
    $ sudo port selfupdate
    $ sudo port install VLC-devel
    
     
  18. meme1255, Sep 16, 2012
    Last edited: Sep 16, 2012

    thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #18
    Something is really weird :( -
    port clean --all
    Can't map the URL 'file://.' to a port description file ("Could not find Portfile in /Users/meme").
    Please verify that the directory and portfile syntax are correct.
    To use the current port, you must be in a port's directory.
     
  19. macrumors Pentium

    KnightWRX

    Joined:
    Jan 28, 2009
    Location:
    Quebec, Canada
    #19
    Sorry, that was my bad, I forgot to tack on the port name there :

    Code:
    $ sudo port clean --all VLC-devel
     
  20. thread starter macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #20
    VLC-devel installed succesfully - except this: When I try run it from terminal, it prints this :

    VLC media player 2.1.0-git Rincewind (revision 1.3.0-git-4012-gac2ccb3)
    [0x7fd689c076a0] main libvlc error: No plugins found! Check your VLC installation.
     

Share This Page