OS X won't mount audio CDs

Discussion in 'macOS' started by ringnebula, May 21, 2006.

  1. ringnebula macrumors newbie

    Joined:
    May 21, 2006
    #1
    I'm running a fresh install of 10.4.3 on a dual 800 Quicksilver. Under OS X audio CDs will not mount. Sometimes I get an error about an unreadable disk but most of the time nothing. Data CDs mount fine as do video and data DVDs. When running OS 9 all optical media is mounted fine.

    Does anyone have a clue as to what direction I might take to fix this? I haven't been able to find much info relevant to this via google so far.

    Thanks!
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Do they mount in iTunes or Disk Utility? :)

    Also, dare I say it, have you repaired permissions recently?
     
  3. russed macrumors 68000

    russed

    Joined:
    Jan 16, 2004
    Location:
    London, England
    #3
    i have had this problem with my powerbook, i just put it down to a failing drive and i havent got around to sending it back to apple yet as i havent been near an apple store/dont have the time to be without it!

    my problem was that i would put it in and it would make clicking noises and spin up and then after a while it would just spit it back out at me! thankfully it appears to have rectified itself now (well it is reading disks!)
     
  4. ringnebula thread starter macrumors newbie

    Joined:
    May 21, 2006
    #4
    Disk Utility shows a cd when I have an audio cd in the drive but will display no info about it. I haven't tried repairing perms yet as this is a fresh install.

    I too figured it was a failed drive so I replaced it with a new one - same problem.

    I'll try repairing the perms now and see what happens.
     
  5. ringnebula thread starter macrumors newbie

    Joined:
    May 21, 2006
    #5
    Ok, so no luck to be had with fixing permissions. There were indeed plenty to be fixed including /System/Library/Filesystems/cddafs.fs

    All fixed now but still no luck mounting audio cds. iTunes does not see the cd either. I have updated to the latest iTunes, but no dice.

    Does anyone have any other suggestions for me? I find it strange that there are no messages logged about this in the system logs.....

    Thanks
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Okay, try dragging CD Info.cidb from your Preferences folder to the Desktop. :)
     
  7. ringnebula thread starter macrumors newbie

    Joined:
    May 21, 2006
    #7
    Thanks for the tip but I'm afraid there is no Info.cidb file on my machine or any .cidb file for that matter. I'm beginning to think that I just have botched install media and that I may have to find a new dvd to install from...
     
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    Weird. Okay, well open a new account and see if it works there, or if you have the CIDB file. :)
     
  9. ringnebula thread starter macrumors newbie

    Joined:
    May 21, 2006
    #9
    No luck with that either I'm afraid. Off to find a new DVD I go
     

Share This Page