OT failing to start?

Discussion in 'Apple Collectors' started by SirFoxx, Jun 9, 2013.

  1. macrumors regular

    Joined:
    Jul 9, 2012
    Location:
    Galien, Michigan
    #1
    Ok so the other day I picked up a performa 6115CD w/ the original 15" CRT for $10. Everything works, so I bought another ethernet adapter off of ebay for the computer so I could hook my performa to a router. I initially bought it so I could transfer files easily, but I also have a game that is multiplayer that I want to try (Descent). Now I know that I can hook the two up using the printer port, but on the Performa it keeps saying that Open Transport isn't started. I thought "hrm, weird...I'm going to try my quadra w/ the PPC card turned on and see what happens." 2 things--with the PPC off and it running on the 68k processor, no OT issues. Turn it on, says OT hasn't started and I should go start it(?). Basically, same problem that the Performa has. If any of this makes sense, any ideas?
     
  2. macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #2
    IIRC, it's due to the fact that these machines were designed before open transport, and the default PRAM (BIOS) setting was for AppleTalk ON and on the printer port.

    I'm sure there's an old Apple tech article about this somewhere, but you may want to check your PRAM batteries. If they're flat, you should see the date & time reset every time mains power is removed.

    Otherwise, try booting up, turn AppleTalk OFF and then restart.
     
  3. SirFoxx, Jun 10, 2013
    Last edited: Jun 10, 2013

    thread starter macrumors regular

    Joined:
    Jul 9, 2012
    Location:
    Galien, Michigan
    #3
    I know the PRAM battery is good because the clock stays the same after the mains is disconnected. Appletalk on the performa is working, however in the Descent game on the Quadra, when I click either host or join, it is telling me to go to chooser and turn on apple talk. So I go to chooser and click active, it is telling me that to make sure that I am connected to an apple talk network, then says apple talk could not be started. Also, when I click the apple talk control panel, it is saying that it cannot be opened because Open Transport has not started. I only get this problem when the PPC card is turned on, and do not get this problem on the 68k processor. My guess is that apple talk and OT are "linked" with each other, and there might be some sort of incompatibility going on? Like the version of OT I have is designed for 68k and not PPC?
     
  4. macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #4
    You may need to either zap the PRAM, and/or use the "Network Software Selector" to toggle from OpenTransport to Classic Networking.

    In other words, if the Network Software Selector says OT is selected, select Classic Networking and shut down the Mac. Then, power on again, and select Open Transport in Network Software Selector and shut down again. This forces the setting to change, rather than persisting with a setting that is somehow corrupted.

    Network Software Selector should be in the "Apple Extras" folder. If not, I think it is in the OT 1.1.2 installer disk.

    There were a few machines that I ran into this problem with. It was such an obscure problem that I can't recall the definitive fix but it involved the Network Software selection, PRAM and Appletalk.

    If you're trying to use AppleTalk over Ethernet, don't forget to use the AppleTalk control panel to switch AppleTalk from the serial port to your Ethernet card (or built-in Ethernet port).

    Appletalk can only be present on one port at a time.

    Also, if you have any third party communications extensions or control panels, drag them out of the System Folder and restart - some didn't like OT. If you haven't installed any, there shouldn't be any (obviously).

    I can't find any references to the PPC Upgrade Card Vs Open Transport - but there may be one. The OT 1.1.2 Read Me says nothing about it.

    So to sum up, all the above may not work, but it's ringing a vague bell for me. :confused:
     
  5. thread starter macrumors regular

    Joined:
    Jul 9, 2012
    Location:
    Galien, Michigan
    #5
    I tried zapping the PRAM and changing the network selection with the network selector with no luck. Oh, with each change, I did shut it down, but it didn't effect anything. Still says appletalk cannot be started when I click activate in the Chooser. I can't access any of the network control panels because it keeps saying that either appletalk isn't started, or OT didn't start, which makes sense since they are both network related. . . The only third party extension / control panel I have is MacIPX, and I removed the extension and appletalk still didn't work.

    I thought that maybe I could reinstall the network part of OS7 with a fresh network installer disc, but when I went to install, it said that the folder "Network" in "Macintosh HD" cannot be replaced. It should be moved to another location or folder so that the files can be installed..or something like that. So that didn't work. I am just kind stumped as to why Appletalk and OT works with the 68k processor and not the PPC processor. Is there a way to maybe transfer the network files from the Performa to the Quadra? They might work since the Performa has 7.5.1 and the Quadra has 7.5.5, but I'm not sure.

    As a side note, I'm not sure how much longer the HDD in my quadra will last. Everytime I start it up for the first time of the day, the hard drive starts clicking repeatedly, kinda like how the IDE hard drives do when they go bad. However, when the computer decides to try and access the files on the HDD, it stops clicking and works just fine...So I am kinda leery as to how much time I have left till the hard drive is completely dead...
     
  6. thread starter macrumors regular

    Joined:
    Jul 9, 2012
    Location:
    Galien, Michigan
    #6
    Well, I decided to re-download OT 1.1.2 from apple's website and reinstall it, and that seemed to fix it. Don't know what it did or replaced, but it fixed it and both computers now can talk to each other through appletalk. I do have to say that the Quadra can play descent alot better than the Performa can xD
     
  7. macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #7
    Hmmm.. I'm thinking that OT 1.1.2 needs to be installed when the PPC Card is installed and running, in order to install the PPC code, otherwise it only installs the 68K code. :mad:

    Although everything I'm reading says that OT runs natively on PPC, but emulated under 68K. :confused:

    Either way, glad to see a reinstall worked. :)
     

Share This Page