OWC Elite Al Pro enclosure problem - argh!!

Discussion in 'Mac Accessories' started by drlunanerd, Sep 1, 2006.

  1. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #1
    I've just had some OWC Elite Al Pro hard drive enclosures delivered.

    One is a quad interface (SATA drive to FireWire 400/800, USB 2 and eSATA).

    I've installed a SATA drive inside. Powered up, plugged into my laptop with FireWire 400. All working great. Copied data, no problems.

    However, after a couple of minutes the external hard drive goes to sleep - I hear it spin down. Once it does that I cannot access it anymore. The Finder locks up.

    Only by turning off and on the external power supply can I get the drive to come back to life. The Finder then complains that the drive hasn't been ejected properly, and I have to unplug and plug back in the FireWire cable.

    What the heck is going on? The label on the power supply says it's a "switching power supply adapter". I think it's bloody cutting the power to the case once the hard drive spins down. It's unusable like this :(

    Has anyone else had this problem?
     
  2. drlunanerd thread starter macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #2
    I've just tried another enclosure, with a different drive in, and it's doing the same thing. Completely dies when the drive spins down. It also remains dead if you unmount the drive, then plug the FireWire cable back into the computer. It should remount, but doesn't.

    Great, I pay a ton for OWC's international shipping and they send 3 faulty enclosures :mad:

    The good news is that the third case, which is a cheaper IDE version, works perfectly. Ironic - I pay extra to get SATA quad interface creamy goodness and it turns out a POS, ha.

    OWC's website is useless for the Elite-AL Pro cases. There's no manuals, no technical information, nothing (that I can find).

    It's possible the problem is the hard drives I'm using, but OWC don't mention anything about compatibilities. I've got a pair of Maxtor DiamondMax 10 300GBs.

    Can anyone who owns one of these cases please chime in with their experiences?
     

Share This Page