painfully slow airport extreme router

Discussion in 'Mac Accessories' started by Grendel, Jul 27, 2006.

  1. Grendel macrumors newbie

    Dec 31, 2003
    I have a cable modem, aiport extreme base, dual 1.8 g5, and an ibook g4. Until today, everything was working perfectly. I powered everything down as there was a major lightning event where I live (florida) and when I powered everything back up again, the internet was extremely slow. If I connect the G5 directly to the cable modem, everything is fine, but if I go through the airport extreme it is slower than dial up.

    I've tried the new firmware for the airport extreme, and a new ethernet cable - anyone have any ideas? Should I take the airport in for repair?

    Thanks -
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    So even if you're hardwired through the Extreme, it's still slow? Ensure that none of the network settings have been changed by matching them up with the settings for the ethernet connection in your Mac. :)
  3. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Is there a chance the major lightning event fried the Airport? I'd expect it to just not work in this event, but if nothing has changed and it suddenly isn't working right, I'd look to the most obvious causes.

    Trying one of the comptuers hardwired through the router (if you haven't already) like mad jew saod would narrow it down; if it's still slow, the whole router is acting up so it's either incoming circuitry not working or there's a setting problem. If that's fine and only the wireless is slow, then you know where to pay most attention to the settings, or if there's a hardware problem where it is...

Share This Page