Pandora via AirPlay to AppleTV skipping

Discussion in 'Apple TV and Home Theater' started by zhenya, Nov 20, 2011.

  1. macrumors 68040

    zhenya

    Joined:
    Jan 6, 2005
    #1
    I've had this problem for some time, but recently it's been worse. I often listen to Pandora via Airplay from my iPad or iPhone transmitting to my AppleTV. Problem is, there are often skips or pauses - sometimes just a couple of seconds once or twice per song, sometimes so frequent that it's unplayable.

    Ok, I understand this is entirely dependent on my network conditions, fine. I really don't think that's the whole story though, because I can switch to streaming to one of the many Airport Expresses I have around the house, and streaming is flawless. If anything, I'd expect the ATV to be more robust, as it's the only one connected via Ethernet. Software on the ATV is fully up to date, and in general my network is extremely reliable (I'm a part-time network engineer). Anyone else have any similar experiences or suggestions?
     
  2. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #2
    Wirelessly posted (iPhone 4S: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Sounds like you have it set up properly and have it connected via Ethernet, which is what I always recommend.

    Is there any other network traffic going on while streaming Pandora?

    I'd also suggest checking the cable ends and test the connections with a Fluke if you have one. Or just swap the cable anyway. See what happens.

    Also, check for wireless interference in the area. It could be interfering with the signal from your iPhone to the router too. Maybe change the channel on the router too.
     
  3. thread starter macrumors 68040

    zhenya

    Joined:
    Jan 6, 2005
    #3
    Sure, there is other network traffic, but like I say, I can switch to an airport express and streaming works fine a moment later. The ATV is also otherwise fine - streaming video from Netflix or via Home Sharing is fine. Music played via the Music apps and AirPlay works fine. Even video over AirPlay works fine. Pandora is the only app that consistently has problems.
     
  4. thread starter macrumors 68040

    zhenya

    Joined:
    Jan 6, 2005
    #4
    Hmm. Investigating the network settings and it turned out that it was using the wireless connection despite having an Ethernet cable inserted. Reseated the cable and it switched interfaces. So far seems to be an improvement, (still not perfect) although it still seems strange that the airport expresses work fine with wireless...
     
  5. macrumors 6502a

    b-rad g

    Joined:
    Jun 29, 2010
    #5
    Make sure your Bluetooth is turned off on your iPhone. I have found that whenever BT is on I get skipping, but if BT is off it plays great with no problems or skips.
     
  6. thread starter macrumors 68040

    zhenya

    Joined:
    Jan 6, 2005
    #6
    Thanks. Bluetooth is off.

    I spoke too soon in saying that things were better. It's just as bad as it was - tons of skips, etc. Yet I can stream high quality video just fine. :rolleyes:
     

Share This Page