Panther Mail regularly using 70-90% CPU

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by simX, Oct 26, 2003.

  1. macrumors 6502a

    simX

    Joined:
    May 28, 2002
    Location:
    Bay Area, CA
    #1
    Is anybody else experiencing the problem where Mail just randomly starts using a ton of your CPU? It started when I was playing the Mac OS X version of Oni -- I had Mail open in the background, and Oni just all of a sudden started jerking around. When I quit Oni, I noticed that typing was significantly slower, too. So then I looked at the CPU usage of all open processes, and Mail was using 70-90% of my CPU!

    Quitting Mail solves the problem (obviously), but opening up again immediately makes it start using up 70-90% of my CPU. This issue survives a restart, as well.

    Note that this is a completely clean install of Panther -- I only manually migrated the settings I absolutely needed from my old Jaguar installation.
     
  2. Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #2
    You're not alone.

    This was also mentioned here.

    Good luck getting that sorted out. Mine's been fine on a clean install. Some people's seems to clear up "on its own", which is always neat but a little odd.
     
  3. macrumors member

    Joined:
    Dec 7, 2002
    #3
    This happened to me, too. Relaunched Mail, kept going. Rebooted. Still going. Then I started clicking around on some of my old imported mail folders with 1000s of messages in them and it started indexing them (which eats CPU). Once it was done indexing the folder, the problem went away (about an hour ago). Though I expect it will return....
     
  4. macrumors newbie

    Joined:
    Oct 27, 2003
    #4
    This happened to me as well. Very frustrating. After some work, I traced it to a missing font in ~/Library/Fonts . In my case, it was Verdana. I have noticed font weirdness very reliably pegs Panther's CPU.

    dpwk
     
  5. macrumors regular

    Joined:
    Oct 23, 2003
    Location:
    US of A
    #5
    I've not noticed it, but i do not monitor my CPU. I will check into it.
     
  6. macrumors member

    Joined:
    Aug 12, 2003
    Location:
    SF Bay Area
    #6
    Could Activity Viewer Help?

    I think this is a new Panther feature, but cmd-0 opens the Activity Window, where it describes what processes the app is engaged in.

    Maybe this could help you out a bit?
     
  7. macrumors regular

    Joined:
    Oct 23, 2003
    Location:
    US of A
    #7
    I checked my own, and it seems Mail uses about 2.4% of my CPU, lol! No problems here...
     
  8. macrumors 68020

    sparkleytone

    Joined:
    Oct 28, 2001
    Location:
    Greensboro, NC
    #8
    yeah this is a randomly occurring problem here too. i have no idea what its doing when it does this, but it is indeed annoying.
     
  9. macrumors 6502

    Muskie

    Joined:
    Dec 1, 2003
    Location:
    Minneapolis
    #9
    Mine just started eating about 95% or more of my cpu. I of course repaired permissions, restarted Mail itself (several times), as well as my computer, to no avail. I did notice something interesting, however, when I click on one of the pull down menus from the menu bar, the cpu usage drops significantly, back to normal or maybe even less. No idea what that means, does anyone else?
     
  10. macrumors 6502

    Joined:
    Dec 24, 2003
    #10
    I believe Mail is compressing or indexing your messages. It does this randomly, it seems, or perhaps only when I need the processor power. Never seems to do it when I'm reading a long thread, only when I'm in the middle of importing data to iMovie or such.

    I do hope Apple figures out a way to do this better. I understand it's necessary, at least to some degree, but jeez.
     
  11. tzm
    macrumors newbie

    Joined:
    Nov 1, 2004
    Location:
    Wis"CON"sin
    #11
    I always leave Mail open when I use my PB. Is it why I can access other problem slightly slower than it was? I don't really know either because I leave more than 6 programs open at the same time, always. (AIM, Safari, MSN Messenger, Yahoo1 Messenger, iTunes)
     
  12. macrumors 6502

    Joined:
    Dec 24, 2003
    #12
    The Mail thing is periodic, and you'll hear your hard drive going like mad when it happens.

    I'd say your slowdown is because of MSN Messenger, although I've never used it. All of the Office apps hog about 10% of the processor, even when they're not in use (minimized or hidden), while every other app I use uses ZERO processor when not front and center.

    I routinely have 16 apps open at any given time, with little to no slowdown. (Konfabulator takes a small toll, but it's always on top.)
     
  13. macrumors newbie

    Joined:
    Jul 16, 2004
    #13
    I have no problem with mail. Around 2.0% :)
     
  14. macrumors member

    Joined:
    Sep 21, 2004
    Location:
    Amsterdam
    #14
    I'm almost certain it has something to do with processing junk mail and maybe other mail rules: I had around 350 junk mails in my junk box, and I have mail configured so that it removes junk mail that's older than 7 days.
    One time, mail started to use 60-70% cpu, and after it stopped doing that, I had 250 junk mails left, none of them older than 7 days.
     

Share This Page