Panther on a mixed network - SLOOOOOW

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by huxley, Nov 11, 2003.

  1. huxley macrumors newbie

    Joined:
    Dec 31, 2001
    Location:
    Chicago
    #1
    I have one of our Macs on Panther now, and overall it's made a good improvement in speed on the system. But I'm wondering about my network speeds...

    All our Macs that are using OSX are noticably slower than the ones still on 9.2.2 - have been since we upgraded. The speed difference wasn't that bad with 10.2.xx, but was still there. All our servers are PC, running either Win2K server or XP server. The Macs are all using assigned IP addresses (both the OS9 and the OSX systems), and have AppleTalk turnd off.

    I've checked and double-checked all the settings I can think of on both the servers and the Macs, and the OSX Macs are just running way too slow. There is something definitely wrong if a 7300/200 can drag-copy a 200mb file before a G4/dual 1.42 can drag copy a 50 mb file.

    Any suggestions - on either the PC or the Mac side... any suggestions at all would be appreciated.
     
  2. will macrumors regular

    Joined:
    Aug 29, 2002
    #2
    It's hard to diagnose the problem without more information.

    Perhaps the OS X network settings are incorrect, or autonegotiation is failing. Are your switches full duplex, and if so are the OS X machines using full duplex (use ifconfig to check)?
     
  3. huxley thread starter macrumors newbie

    Joined:
    Dec 31, 2001
    Location:
    Chicago
    #3
    looks like the machines are using half-duplex - where do i change this?
     
  4. will macrumors regular

    Joined:
    Aug 29, 2002
    #4
    sudo ifconfig en0 mediaopt full-duplex

    See if that fixes it (assuming your ethernet interface is en0).

    NB. I haven't tested this on a Mac, I'm just going on the basis of the usual ifconfig command.

    You can change back to half duplex by running the same command with 'half-duplex'.
     
  5. huxley thread starter macrumors newbie

    Joined:
    Dec 31, 2001
    Location:
    Chicago
    #5
    sorry - i don't mean to be such a pain here, but how do i change this setting? i typed your suggestion into terminal, and it did not change my settings.
     
  6. will macrumors regular

    Joined:
    Aug 29, 2002
    #6
    Perhaps it doesn't work on the Mac. I'm not currently on a Mac with ethernet, so can't check. Try googling for duplex and OS X, and I'm sure you'll come up with a tool.
     
  7. notkevin macrumors member

    Joined:
    Mar 26, 2003
    #7
    You can change the duplex settings via GUI by going to:

    System Preferece -> Network -> Ethernet -> Configure -> Ethernet -> Configure -> Manual
     
  8. huxley thread starter macrumors newbie

    Joined:
    Dec 31, 2001
    Location:
    Chicago
    #8
    Well, that didn't work - that lost my network connection completely, and could not connect to the network at all. Then, when I reset my config to "automatic" and run the ifconfig cmd again, it tells me that i have been automatically set to half-duplexing.

    I'm starting to wonder if it could be an issue between the Mac and the hubs - I am connecting to an Asanté 8-port 10/100 auto-sensing hub - could that be affecting the half-duplexing?
     
  9. notkevin macrumors member

    Joined:
    Mar 26, 2003
    #9
    I also had the problem at home where I was getting Dial up speed on my LAN at home. Sure enough, when I exchanged my 100bt switch for a cheap 10bt hub it worked fine.
     
  10. iTron macrumors newbie

    Joined:
    Jun 23, 2003
    #10
    I'm curious are the 9.2.2 machines all set at 1/2 duplex as well? I'm guessing they are, i don't think the dupluxing is the problem, well atleast it's not in my case, below is a question i posted in another forum, i'm having similar problems but i think on another level worse then your experiencing.

    <quote>
    I was wondering if anyone has noticed really really slow network transfers. Before i installed panther i transferred all my files ( about 29gb ) to a windows box, i then did a clean install of panther. This is on a dual 1.25ghz g4. The i tried to transfer the files back over and it's ungodly slow. It took 14 hours to transfer 7.5gb's. To test if it was the windows box or the network cables or hub connection i did a transfer between 2 of my windows machines and it was normal speed. I then moved the mac to the connection that one of the windows machines was on and tried again, it was just as horridly slow. I have windows sharing and personal file sharing turned on just for reference.

    I did notice a couple things about the transfer in activity monitor, it would transfer at a decent rate and then drop to about 0 transfer rate and then climb and kept doing this. Also i noticed as i transferred files my free ram kept dropping. It dropped 200mb in like 1/2 hour. I have 768mb on this system and it was eventually down to like 7mb of free ram and the only thing running was activity monitor.

    I had heard a rumor that their was a problem with the 1gb connection under panther so i forced it to 100mb and still the same problem. My network is 10/100 by the way. The hub is only a 1/2 duplex hub so it's not getting the wrong reading their, under jaguar and panther both it's 1/2 duplex.

    To try and verify if it was maybe samba causing this, i turned on ftp and did a transfer from the pc to the mac and it transferred at normal speed. Just for testing i did an ftp transfer from the mac up to the pc as well and again that transferred normally.

    Infact to transfer the remaining 22gb to the mac i opened 5 simultaneous connections to the mac and dropped the files down at lightning speeds.

    Also the copies to and from this same mac worked fine under jaguar.

    </quote>
     
  11. 7on macrumors 601

    7on

    Joined:
    Nov 9, 2003
    Location:
    Dress Rosa
    #11
    Try turning Appletalk on, in Network under System Preferences and in Directory Access in Applications:Utilities
     
  12. huxley thread starter macrumors newbie

    Joined:
    Dec 31, 2001
    Location:
    Chicago
    #12
    AppleTalk causes excessive chatter on a network - especially in a production environment. If I turn AppleTalk on, then I have constant broadcasting from the Macs across the network. That's why I'm using TCP/IP - to NOT have to use AppleTalk in my LAN.

    I have three PC servers that I am accessing... the problem is not accessing the servers, the problem is the speed of the access. Turning on AppleTalk will just increase the network traffic, and make a slow connection even slower. Unless there's something new in AppleTalk that I am not aware of...?
     
  13. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #13
    No, don't bother with it. Anyways, it sounds like either Samba itself or Panther's Samba support is the problem.
     
  14. bhancock macrumors newbie

    Joined:
    Nov 12, 2003
    #14
    Use Dave

    Dave is better for windows networking. OS X is basically a dog. It is much easier to pull or push data from the windows machine than the mac. I figure that the network speed with Panther on the mac end must be about 10Mbps and not 100.
     
  15. VegetaPunk macrumors 6502

    Joined:
    Dec 30, 2002
    Location:
    AZ
    #15
    I had a similar problem a long time ago with OS X, I pinged the other computer on the network and found out that it was transfering over the internet and not through the network. This part of the address was different xxx.xxx.XXX.xxx Although on my current network I dont have this problem, I do have a router now and before I was using a hub......
     

Share This Page