Parallels: Open URLS in Mac Safari

Discussion in 'Mac Applications and Mac App Store' started by lieb39, May 4, 2008.

  1. macrumors 6502

    lieb39

    Joined:
    Mar 17, 2005
    Location:
    Melbourne, Australia
    #1
    Hello everyone,

    I'm bashing my head aganist the keyboard to get this working..

    I switched from VMWare to Parallels just for this feature..

    All I want is the following:

    When having Outlook 2007 open in my Virtual machine in Parallels, and I click a LINK in a email, it opens in Safari on my Host machine.

    How do I set this up?

    Thanks.

    lieb39
     
  2. macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #2
    Try this...

    In your Windows VM, Launch IE.
    Under the Tools Menu -> Internet Options -> Programs Tab
    Email Settings: Outlook
    Default Web Browser: make IE your default
    Click Apply

    I don't know if this will correct the problem but it won't hurt.

    I don't do email in my VM, but on the Mac Side using Entourage (part of Office 2008).
     
  3. thread starter macrumors 6502

    lieb39

    Joined:
    Mar 17, 2005
    Location:
    Melbourne, Australia
    #3
    No luck. Just to clarify, I want to have all webpages open on my mac - in safari.

    E.g. Clicking on a webpage link in an email (on my guest OS) will open it on my mac.

    Thanks,

    lieb39
     
  4. macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #4
    Sorry, I misread your post. I thought you wanted the opposite (to have all URLs in VM to open in a browser in VM).

    I'm not sure what you want is possible since you are reading your email in a "Virtual Machine".

    Have your tried doing the following?:
    Set Safari to be your default browser (MacOS)?
    Tried running Parallels in "Coherence Mode"?
    You can also install the Windows version of Safari in your VM.
     
  5. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    This IS doable, at least in Parallels 3.0. What you have to do is tell Windows to use Safari (Mac) as its default browser. This program can be found in the Windows Start Menu, in the Parallels exported applications section.
     
  6. thread starter macrumors 6502

    lieb39

    Joined:
    Mar 17, 2005
    Location:
    Melbourne, Australia
    #6
    How is it dooable though? I've read countless reviews saying they've got it work.. but for the life of me, I can't.

    Cheers
     
  7. macrumors G4

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #7
    First of all, do you have export Mac applications to Windows enabled? This is required, for it to work.

    Then, just find the default browser setting in Windows (I have no idea where this is stored), and change it to Safari (Mac).
     
  8. thread starter macrumors 6502

    lieb39

    Joined:
    Mar 17, 2005
    Location:
    Melbourne, Australia
    #8
    Yeah its the last part I'm struggling with.. Everyone I find a way it doesn't work.

    This is hard for something that shoulkd work out of the box.. Or so it seems.

    Cheers
     
  9. macrumors newbie

    Joined:
    Mar 29, 2010
    #9
    Same Issue

    Same problem. Tried to reassign the default browser to be the safari (mac) app shared application, but it appears that the VM Shared Apps are not registered on the windows side as applications. Oddly, I could assign them to specific file types (.html, etc.), but not to protocols (http). Anyone know how to do that?
     
  10. macrumors newbie

    Joined:
    May 13, 2010
    #10
    How to open URLs on the Mac from Windows in Parallels

    Go into your Virtual Machine Configuration, on the left menu select "Internet Applications" and the right toggle "Web Pages" to say "Open in Mac OS X".
     
  11. hom
    macrumors newbie

    Joined:
    Sep 23, 2010
    #11
    Thanks!

    Found this page via google search, and the post just above is exactly what I was looking for. Worked great, thanks!
     
  12. macrumors regular

    Pwned

    Joined:
    May 12, 2008
    Location:
    Washington DC
    #12
    Thank you!

    This solved my issue, thanks for your help all!
     

Share This Page